- NetBSD Manual Pages
EN(4) NetBSD/vax Kernel Interfaces Manual EN(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
en -- Xerox 3 Mb/s Ethernet interface
en0 at uba0 csr 161000 vector enrint enxint encollide
NOTE: This driver has not been ported from 4.4BSD yet.
The en interface provides access to a 3 Mb/s Ethernet network. Due to
limitations in the hardware, DMA transfers to and from the network must
take place in the lower 64K bytes of the UNIBUS address space, and thus
this must be among the first UNIBUS devices enabled after boot.
Each of the host's network addresses is specified at boot time with an
SIOCSIFADDR ioctl(2). The station address is discovered by probing the
on-board Ethernet address register, and is used to verify the protocol
addresses. No packets will be sent or accepted until a network address
The interface software implements an exponential backoff algorithm when
notified of a collision on the cable. This algorithm uses a 16-bit mask
and the VAX-11's interval timer in calculating a series of random backoff
values. The algorithm is as follows:
1. Initialize the mask to be all 1's.
2. If the mask is zero, 16 retries have been made and we give up.
3. Shift the mask left one bit and formulate a backoff by masking
the interval timer with the mask (this is actually the two's
complement of the value).
4. Use the value calculated in step 3 to delay before retransmit-
ting the packet.
en%d: output error. The hardware indicated an error on the previous
en%d: send error. After 16 retransmissions using the exponential backoff
algorithm described above, the packet was dropped.
en%d: input error. The hardware indicated an error in reading a packet
off the cable.
en%d: can't handle af%d. The interface was handed a message with
addresses formatted in an unsuitable address family; the packet was
The en driver appeared in 4.2BSD.
The device has insufficient buffering to handle back to back packets.
This makes use in a production environment painful.
The hardware does word at a time DMA without byte swapping. To compen-
sate, byte swapping of user data must either be done by the user or by
the system. A kludge to byte swap only IP packets is provided if the
ENF_SWABIPS flag is defined in the driver and set at boot time with an
NetBSD 9.99 February 5, 2019 NetBSD 9.99