- NetBSD Manual Pages
UVIDEO(4) NetBSD Kernel Interfaces Manual UVIDEO(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
uvideo -- USB video device driver
uvideo* at uhub?
video* at videobus?
The uvideo driver provides support for USB video class devices.
A USB video device consists of a number of components. Every device has
one control interface. Each device optionally provides streaming inter-
faces (input or output).
usb(4), video(4), video(9)
USB Approved Class Specification Documents,
Patrick Mahoney <firstname.lastname@example.org>
Does not support all of UVC spec. Only supports the one streaming input
interface. Does not support the interrupt endpoint for some controls.
Exports the Video4Linux2 API via video(9), and V4L2 lacks support for
some UVC features such as still images.
NetBSD 9.99 September 20, 2011 NetBSD 9.99