- NetBSD Manual Pages
MDNSD(8) NetBSD System Manager's Manual MDNSD(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
mdnsd -- Multicast and Unicast DNS daemon
mdnsd (also known as mDNSResponder on some systems) is a daemon invoked
at boot time to implement Multicast DNS and DNS Service Discovery. On
Mac OS X 10.6 (Snow Leopard), mdnsd is also the system-wide Unicast DNS
mdnsd listens on UDP port 5353 for Multicast DNS Query packets. When it
receives a query for which it knows an answer, mdnsd issues the appropri-
ate Multicast DNS Reply packet.
mdnsd also performs Unicast and Multicast DNS Queries on behalf of client
processes, and maintains a cache of the replies.
mdnsd has no user-specifiable command-line argument, and users should not
run mdnsd manually.
There are several methods with which to examine mdnsd's internal state
for debugging and diagnostic purposes. The syslogd(8) logging levels map
Error - Error messages
Warning - Client-initiated operations
Notice - Sleep proxy operations
Info - Informational messages
By default, only log level Error is logged.
A SIGUSR1 signal toggles additional logging, with Warning and Notice
enabled by default:
# pkill -USR1 mdnsd
A SIGUSR2 signal toggles packet logging:
# pkill -USR2 mdnsd
A SIGINFO signal will dump a snapshot summary of the internal state to
# pkill -INFO mdnsd
dns-sd(1), pkill(1), syslogd(8)
For information on Multicast DNS, see http://www.multicastdns.org/
For information on DNS Service Discovery, see http://www.dns-sd.org/
For information on how to use the Multicast DNS and the DNS Service Dis-
covery APIs on Mac OS X and other platforms, see
For the source code to mdnsd, see
The mdnsd daemon first appeared in Mac OS X 10.2 (Jaguar).
Also available from the Darwin open source repository (though not offi-
cially supported by Apple) are mdnsd daemons for other platforms, includ-
ing Mac OS 9, Microsoft Windows, Linux, FreeBSD, NetBSD, Solaris, and
other POSIX systems.
mdnsd bugs are tracked in Apple Radar component "mDNSResponder".
NetBSD 10.99 February 27, 2011 NetBSD 10.99