- NetBSD Manual Pages
IGMAFB(4) NetBSD Kernel Interfaces Manual IGMAFB(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
igmafb -- Intel Graphics Media Accelerator framebuffer driver
no options VGA_POST
no device at drm
igma0 at pci0 dev ? function ?
igmafb* at igma0
iic* at igma0
The igmafb driver provides support for integrated graphics functions in
Intel chipsets and provides an interface for the machine independent
Currently igmafb configures the display for the integrated panel in note-
books and can control the backlight. Automatic detection of the main
display on desktop machines may or may not work.
Supported hardware includes:
· GMA 900 (915G)
· GMA 950 (945G)
· GMA 3000 (Q965)
· GMA X3000 (G965)
· GMA X3500 (G35)
· GMA X4500 (G45)
· HD (Westmere)
· HD2000/3000 (Sandy Bridge)
· HD2500/4000 (Ivy Bridge)
The igmafb driver was written by Michael van Elst.
The driver conflicts with genfb(4), agp(4), and thus with drm(4). Sup-
port for a hardware cursor is missing.
NetBSD 10.99 January 21, 2014 NetBSD 10.99