- NetBSD Manual Pages
HDAUDIOCTL(8) NetBSD System Manager's Manual HDAUDIOCTL(8)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
hdaudioctl -- program to manipulate hdaudio(4) devices
hdaudioctl [-f device] command [arguments]
The hdaudioctl command can be used to inspect and reconfigure High Defi-
nition Audio devices and their child codecs.
The mandatory command argument specifies the action to take. Valid com-
list For each child codec of the chosen hdaudio(4) device,
display the nid, vendor, product, subsystem and device
show Retrieve and display the current codec configuration
in human-readable form.
get codecid nid Retrieve and display the current codec configuration
as a proplib(3) XML plist.
set codecid nid [plist]
Detach the specified hdafg(4) codec and then re-attach
with its widgets explicitly configured according to
the specified plist. If no plist is given, the in-
built widget parsing rules based on the High Defini-
tion Audio specification will be used.
graph codecid nid Output a DOT file suitable processing by graphviz.
The resulting image will graphically show the struc-
ture and interconnections of the widgets that form the
chosen hdafg(4) codec.
/dev/hdaudioX control devices
audio(4), hdaudio(4), pkgsrc/graphics/graphviz
The hdaudioctl command first appeared in NetBSD 5.1.
hdaudioctl is based on two separate programs written by Jared McNeill
<jmcneill@NetBSD.org> under contract by Precedence:
http://www.precedence.co.uk/ Technologies Ltd.
Integration into one program and writing this manual page was done by
Stephen Borrill <sborrill@NetBSD.org>.
When a plist is loaded and the hdafg(4) codec reattaches, all mixer con-
trols will be returned to their default values.
NetBSD 9.99 June 12, 2020 NetBSD 9.99