- NetBSD Manual Pages
GPIOLOCK(4) NetBSD Kernel Interfaces Manual GPIOLOCK(4)
Powered by man-cgi 1.15, Panagiotis Christias
gpiolock -- support for multi-position keylocks attached to GPIO pins
gpiolock* at gpio? offset ? mask ?
gpiolock* at gpio?
The gpiolock driver allows connecting of multi-position keylocks over
GPIO pins. The keylock driver registers with an in-kernel keylock sup-
porting system and provides kauth(9) support through an experimental
security model. The keylock state can be queried using the hw.keylock
sysctl variables. Only locks with 2-4 positions are currently supported.
The pin number is specified in the kernel configuration with the offset
locator. The mask locator denotes the pins used for the lock (minimum 2,
maximum 4 pins are used). The offset and mask can also be specified when
gpiolock is attached at runtime using the GPIOATTACH ioctl(2) on the
The gpiolock driver first appeared in NetBSD 6.0.
The gpiolock driver was written by Marc Balmer <email@example.com>.
NetBSD 9.99 August 21, 2009 NetBSD 9.99
Modified for NetBSD
by Kimmo Suominen