- NetBSD Manual Pages
GETTYTAB(5) NetBSD File Formats Manual GETTYTAB(5)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
gettytab -- terminal configuration data base
The gettytab file is a simplified version of the capfile(5) data base
used to describe terminal lines. The initial terminal login process
getty(8) accesses the gettytab file each time it starts, allowing simpler
reconfiguration of terminal characteristics. Each entry in the data base
is used to describe one class of terminals.
Where to run getty(8) processes is normally defined by ttys(5).
There is a default terminal class, default, that is used to set global
defaults for all other classes. (That is, the default entry is read,
then the entry for the class required is used to override particular set-
tings.) The default entry is also normally read by other programs that
present login prompts to the user, such as telnetd(8), in order to
retrieve the values of the he, hn, im, and if capabilities.
Refer to capfile(5) for a description of the file layout. The `Default'
column below lists defaults obtained if there is no entry in the table
obtained, nor one in the special default table.
Name Type Default Description
ab bool false Auto-baud speed select mechanism for
the Micom 600 portselector. Selection
is done by looking at how the character
`\r' is garbled at 300, 1200, 4800, and
al str NULL user to auto-login instead of prompting
ap bool false terminal uses any parity
bk str \377 alternative end of line character
(input break) (VEOL)
b2 str \377 alternative end of line character
(input break) (VEOL2)
c0 num unused tty control flags to write messages
c1 num unused tty control flags to read login name
c2 num unused tty control flags to leave terminal as
ce bool false use CRT erase algorithm
ck bool false use CRT kill algorithm
cl str NULL screen clear sequence
co bool false console - add `\r\n' after login prompt
cs bool false clear screen based on terminal type in
ds str `^Y' delayed suspend character (VDSUSP)
dx bool false set DECCTLQ
ec bool false leave echo OFF
ep bool false terminal uses even parity
er str `^?' erase character (VERASE)
et str `^D' end of text (VEOF) character
ev str NULL initial environment
f0 num unused tty mode flags to write messages
f1 num unused tty mode flags to read login name
f2 num unused tty mode flags to leave terminal as
fl str `^O' output flush character (VDISCARD)
hc bool false do NOT hangup line on last close
he str NULL hostname editing string
hn str hostname hostname
ht bool false terminal has real tabs
i0 num unused tty input flags to write messages
i1 num unused tty input flags to read login name
i2 num unused tty input flags to leave terminal as
if str NULL display named file before prompt, like
ig bool false ignore garbage characters in login name
im str NULL initial (banner) message
in str `^C' interrupt character (VINTR)
is num unused input speed
kl str `^U' kill character (VKILL)
l0 num unused tty local flags to write messages
l1 num unused tty local flags to read login name
l2 num unused tty local flags to leave terminal as
lc bool false terminal has lower case
lm str login: login prompt
ln str `^V' `literal next' character (VLNEXT)
lo str /usr/bin/login program to exec when name obtained
mb bool false do flow control based on carrier
nl bool false terminal has (or might have) a newline
nn bool false do not prompt for a login name
np bool false terminal uses no parity (i.e. 8-bit
nx str default next table (for auto speed selection)
o0 num unused tty output flags to write messages
o1 num unused tty output flags to read login name
o2 num unused tty output flags to leave terminal as
op bool false terminal uses odd parity
os num unused output speed
pc str `\0' pad character
pe bool false use printer (hard copy) erase algorithm
pf num 0 delay between first prompt and
following flush (seconds)
pp str unused PPP authentication program
ps bool false line connected to a MICOM port selector
qu str `^\' quit character (VQUIT)
rp str `^R' line retype character (VREPRINT)
rw bool false do NOT use RAW for input, use CBREAK
sp num unused line speed (input and output)
st str `^T' status character (VSTATUS)
su str `^Z' suspend character (VSUSP)
tc str none table continuation
to num 0 timeout (seconds)
tt str NULL terminal type (for environment)
ub bool false do unbuffered output (of prompts etc)
we str `^W' word erase character (VWERASE)
xc bool false do NOT echo control chars as `^X'
xf str `^S' XOFF (stop output) character (VSTOP)
xn str `^Q' XON (start output) character (VSTART)
The following capabilities are no longer supported by getty(8):
bd num 0 backspace delay
cb bool false use CRT backspace mode
cd num 0 carriage-return delay
fd num 0 form-feed (vertical motion) delay
nd num 0 newline (line-feed) delay
uc bool false terminal is known upper case only
If no line speed is specified, speed will not be altered from that which
prevails when getty is entered. Specifying an input or output speed will
override line speed for stated direction only.
Terminal modes to be used for the output of the message, for input of the
login name, and to leave the terminal set as upon completion, are derived
from the boolean flags specified. If the derivation should prove inade-
quate, any (or all) of these three may be overridden with one of the c0,
c1, c2, i0, i1, i2, l0, l1, l2, o0, o1, or o2 numeric specifications,
which can be used to specify (usually in octal, with a leading `0') the
exact values of the flags. These flags correspond to the termios
c_cflag, c_iflag, c_lflag, and c_oflag fields, respectively. Each these
sets must be completely specified to be effective. The f0, f1, and f2
are excepted for backwards compatibility with a previous incarnation of
the TTY sub-system. In these flags the bottom 16 bits of the (32 bits)
value contain the sgttyb sg_flags field, while the top 16 bits represent
the local mode word.
Should getty(8) receive a null character (presumed to indicate a line
break) it will restart using the table indicated by the nx entry. If
there is none, it will re-use its original table.
Delays are specified in milliseconds, the nearest possible delay avail-
able in the tty driver will be used. Should greater certainty be
desired, delays with values 0, 1, 2, and 3 are interpreted as choosing
that particular delay algorithm from the driver.
The cl screen clear string may be preceded by a (decimal) number of mil-
liseconds of delay required (a la termcap). This delay is simulated by
repeated use of the pad character pc.
The initial message im, and login message lm may include any of the fol-
lowing character sequences, which expand to information about the envi-
ronment in which getty(8) is running.
%d The current date.
%h The hostname of the machine, which is normally obtained from the
system using gethostname(3), but may also be overridden by the hn
table entry. In either case it may be edited with the he string.
A `@' in the he string causes one character from the real hostname
to be copied to the final hostname. A `#' in the he string causes
the next character of the real hostname to be skipped. Each char-
acter that is neither `@' nor `#' is copied into the final host-
name. Surplus `@' and `#' characters are ignored.
%t The tty name.
%m, %r, %s, %v
The type of machine, release of the operating system, name of the
operating system, and version of the kernel, respectively, as
returned by uname(3).
%% A `%' character.
When getty execs the login process, given in the lo string (usually
``/usr/bin/login''), it will have set the environment to include the ter-
minal type, as indicated by the tt string (if it exists). The ev string,
can be used to enter additional data into the environment. It is a list
of comma separated strings, each of which will presumably be of the form
If a non-zero timeout is specified, with to, then getty will exit within
the indicated number of seconds, either having received a login name and
passed control to login(1), or having received an alarm signal, and
exited. This may be useful to hangup dial in lines.
Output from getty(8) is even parity unless op or np is specified. The op
string may be specified with ap to allow any parity on input, but gener-
ate odd parity output. Note: this only applies while getty is being run,
terminal driver limitations prevent a more complete implementation.
getty(8) does not check parity of input characters in RAW mode.
If pp string is specified and a Point to Point Protocol (PPP) link
bringup sequence is recognized, getty(8) will invoke the program refer-
enced by the pp string, e.g. pppd(8). This can be used to handle incom-
ing PPP calls.
login(1), gethostname(3), uname(3), capfile(5), ttys(5), getty(8),
The gettytab file format appeared in 4.2BSD.
The special characters (erase, kill, etc.) are reset to system defaults
by login(1). In all cases, `#' or `^H' typed in a login name will be
treated as an erase character, and `@' will be treated as a kill charac-
The delay stuff is a real crock. Apart from its general lack of flexi-
bility, some of the delay algorithms are not implemented. The terminal
driver should support sane delay settings.
The he capability is stupid.
NetBSD 10.99 April 5, 2012 NetBSD 10.99