- NetBSD Manual Pages
DM(4) NetBSD Kernel Interfaces Manual DM(4)
Powered by man-cgi (2021-03-02).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
dm -- Device-mapper disk driver
The dm driver provides the capability of creating one or more virtual
disks based on the target mapping.
This document assumes that you're familiar with how to generate kernels,
how to properly configure disks and pseudo-devices in a kernel configura-
tion file, and how to partition disks. This driver is used by the Linux
lvm2tools to create and manage lvm in NetBSD.
Currently, the linear, zero, and error targets are implemented. Each
component partition should be offset at least 2 sectors from the begin-
ning of the component disk. This avoids potential conflicts between the
component disk's disklabel and dm's disklabel. In i386 it is offset by
65 sectors, where 63 sectors are the initial boot sectors and 2 sectors
are used for the disklabel which is set to be read-only.
In order to compile in support for dm, you must add a line similar to the
following to your kernel configuration file:
pseudo-device dm #device-mapper disk device
dm may create linear mapped devices, zero, and error block devices. Zero
and error block devices are used mostly for testing. Linear devices are
used to create virtual disks with linearly mapped virtual blocks to
blocks on real disk. dm Device-mapper devices are controlled through the
/dev/mapper/control device. For controlling this device ioctl(2) calls
are used. For the implementation of the communication channel, the
proplib(3) library is used. The protocol channel is defined as a proplib
dictionary with needed values. For more details, look at
sys/dev/dm/netbsd-dm.h. Before any device can be used, every device-map-
per disk device must be initialized. For initialization one line must be
passed to the kernel driver in the form of a proplib dictionary. Every
device can have more than one table active. An example for such a line
0 10240 linear /dev/wd1a 384
The first parameter is the start sector for the table defined with this
line, the second is the length in sectors which is described with this
table. The third parameter is the target name. All other parts of this
line depend on the chosen target.
For the linear target, there are two additional parameters: The fourth
parameter describes the disk device to which the device-mapper disk is
mapped. The fifth parameter is the offset on this disk from the start of
config(1), proplib(3), dmsetup(8), fsck(8), lvm(8), MAKEDEV(8), mount(8),
The device-mapper disk driver first appeared in NetBSD 6.0.
Adam Hamsik <haad@NetBSD.org> implemented the device-mapper driver for
Brett Lymn <blymn@NetBSD.org>,
Reinoud Zandijk <reinoud@NetBSD.org>, and
Bill Stouder-Studenmund <wrstuden@NetBSD.org> provided guidance and
answered questions about the NetBSD implementation.
This driver is still a work-in-progress -- there can be bugs.
NetBSD 9.99 April 4, 2015 NetBSD 9.99