- NetBSD Manual Pages
DBSYM(8) NetBSD System Manager's Manual DBSYM(8)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
dbsym -- copy kernel symbol table into db_symtab space
dbsym [-Ppv] [-b bfdname] kernel
dbsym is used to copy the symbol table in a newly linked kernel into the
db_symtab array (in the data section) so that the ddb(4) kernel debugger
can find the symbols. This program is only used on systems for which the
boot program does not load the symbol table into memory with the kernel.
The space for these symbols is reserved in the data segment using a con-
fig option like:
The size of the db_symtab array (the value of SYMTAB_SPACE) must be at
least as large as the kernel symbol table. If insufficient space is
reserved, dbsym will refuse to copy the symbol table.
To recognize kernel executable format, the -b flag specifies BFD name of
If the -P flag is given, dbsym will report the size of the kernel symbol
If the -p flag is given, dbsym will report the size of the kernel symbol
table and the size of the db_symtab space. Two values are printed out in
a line separated by a space.
If the -v flag is given, dbsym will print out status information as it is
copying the symbol table.
Note that debugging symbols are not useful to the ddb(4) kernel debugger,
so to minimize the size of the kernel, one should either compile the ker-
nel without debugging symbols (no -g flag) or use the strip(1) command to
strip debugging symbols from the kernel before dbsym is used to copy the
symbol table. The command
strip -d netbsd
will strip out debugging symbols.
NetBSD 9.99 August 14, 2014 NetBSD 9.99