coredump_write(9) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
COREDUMP_WRITE(9)      NetBSD Kernel Developer's Manual      COREDUMP_WRITE(9)


NAME
coredump_write -- common coredump write routine
SYNOPSIS
#include <sys/signalvar.h> int coredump_write(void *iocookie, enum uio_seg segflg, const void *data, size_t len);
DESCRIPTION
coredump_write() is used by both machine-dependent and machine-indepen- dent components to write information to a coredump. iocookie is an opaque pointer that was supplied to the caller of coredump_write(). segflg indicates where the data is located, system space or user space. data points to the information to be written to the coredump. len is the amount of data to be written. coredump_write() returns 0 on success and an appropriate error code on failure.
CODE REFERENCES
Process core dumps are initiated within the file sys/kern/kern_sig.c. Process core dumps for ELF NetBSD binaries are performed within the files sys/kern/core_elf32.c or sys/kern/core_elf64.c. Process core dumps for other NetBSD binaries are performed within the file sys/kern/core_netbsd.c.
SEE ALSO
cpu_coredump(9) NetBSD 10.99 December 24, 2005 NetBSD 10.99
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.