- NetBSD Manual Pages
AUTOFS(5) NetBSD File Formats Manual AUTOFS(5)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
autofs -- automounter filesystem
The autofs driver is the kernel component of the automounter infrastruc-
ture. Its job is to pass mount requests to the automountd(8) daemon, and
pause the processes trying to access the automounted filesystem until the
mount is completed. It is mounted by the automount(8).
These options are available when mounting autofs file systems:
Mount options for all filesystems specified in the map entry.
Filesystem mountpoint prefix.
To unmount all mounted autofs filesystems:
umount -At autofs
To mount autofs filesystems specified in auto_master(5):
auto_master(5), automount(8), automountd(8), autounmountd(8),
The autofs driver first appeared in FreeBSD 10.1. The autofs driver
first appeared in DragonFly 4.5. The autofs driver first appeared in
The autofs was developed by Edward Tomasz Napierala <trasz@FreeBSD.org>
under sponsorship from the FreeBSD Foundation.
The autofs was ported to DragonFly and NetBSD by Tomohiro Kusumi
NetBSD 9.99 November 25, 2017 NetBSD 9.99