- NetBSD Manual Pages
ATHN(4) NetBSD Kernel Interfaces Manual ATHN(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
athn -- Atheros IEEE 802.11a/g/n wireless network device
athn* at cardbus?
athn* at pci?
athn* at uhub? port ?
The athn driver provides support for a wide variety of Atheros 802.11n
devices, ranging from the AR5008 up to the AR9287.
The AR5008 (codenamed Owl) is the first generation of Atheros 802.11n
solutions. It consists of two chips, a MAC/Baseband Processor and a
Radio-on-a-Chip. The MAC/Baseband Processor can be an AR5416 (PCI and
CardBus form factors) or an AR5418 (PCIe Mini Card form factor). The
radio can be an AR2122, AR2133, AR5122 or an AR5133 chip. The AR2122
chip operates in the 2GHz spectrum and supports up to 2 transmit paths
and 2 receiver paths (2T2R). The AR2133 chip operates in the 2GHz spec-
trum and supports up to 3 transmit paths and 3 receiver paths (3T3R).
The AR5122 chip operates in the 2GHz and 5GHz spectra and supports up to
2 transmit paths and 2 receiver paths (2T2R). The AR5133 chip operates
in the 2GHz and 5GHz spectra and supports up to 3 transmit paths and 3
receiver paths (3T3R).
The AR9001 (codenamed Sowl) is a Mini-PCI 802.11n solution. It consists
of two chips, an AR9160 MAC/Baseband Processor and an AR9103 or AR9106
Radio-on-a-Chip. The AR9103 chip operates in the 2GHz spectrum and sup-
ports up to 3 transmit paths and 3 receiver paths (3T3R). The AR9106
chip operates in the 2GHz and 5GHz spectra and supports up to 3 transmit
paths and 3 receiver paths (3T3R).
The AR9220, AR9223 and AR9280 (codenamed Merlin) are the first generation
of Atheros single-chip 802.11n solutions. The AR9220 and AR9223 exist in
PCI and Mini-PCI form factors. The AR9280 exists in PCIe Mini Card
(XB92), half Mini Card (HB92) and USB 2.0 (AR9280+AR7010) form factors.
The AR9220 and AR9280 operate in the 2GHz and 5GHz spectra and support 2
transmit paths and 2 receiver paths (2T2R). The AR9223 operates in the
2GHz spectrum and supports 2 transmit paths and 2 receiver paths (2T2R).
The AR9281 is a single-chip PCIe 802.11n solution. It exists in PCIe
Mini Card (XB91) and half Mini Card (HB91) form factors. It operates in
the 2GHz spectrum and supports 1 transmit path and 2 receiver paths
The AR9285 (codenamed Kite) is a single-chip PCIe 802.11n solution that
targets the value PC market. It exists in PCIe half Mini Card (HB95)
form factor only. It operates in the 2GHz spectrum and supports a single
stream (1T1R). It can be combined with the AR3011 chip to form a combo
WiFi/Bluetooth device (WB195).
The AR9271 is a single-chip USB 2.0 802.11n solution. It operates in the
2GHz spectrum and supports a single stream (1T1R).
The AR2427 is a single-chip PCIe 802.11b/g solution similar to the other
AR9280 solutions but with 802.11n capabilities removed. It exists in
PCIe Mini Card form factor only. It operates in the 2GHz spectrum.
The AR9227 and AR9287 are single-chip 802.11n solutions that target mid-
tier PCs. The AR9227 exists in PCI and Mini-PCI form factors. The
AR9287 exists in PCIe half Mini Card (HB97) and USB 2.0 (AR9287+AR7010)
form factors. They operate in the 2GHz spectrum and support 2 transmit
paths and 2 receiver paths (2T2R).
The following table summarizes the supported chips and their capabili-
Chipset Spectrum TxR:S Bus
AR5008-2NG (AR5416+AR2122) 2GHz 2x2:2 PCI/CardBus
AR5008-3NG (AR5416+AR2133) 2GHz 3x3:2 PCI/CardBus
AR5008-2NX (AR5416+AR5122) 2GHz/5GHz 2x2:2 PCI/CardBus
AR5008-3NX (AR5416+AR5133) 2GHz/5GHz 3x3:2 PCI/CardBus
AR5008E-2NG (AR5418+AR2122) 2GHz 2x2:2 PCIe
AR5008E-3NG (AR5418+AR2133) 2GHz 3x3:2 PCIe
AR5008E-2NX (AR5418+AR5122) 2GHz/5GHz 2x2:2 PCIe
AR5008E-3NX (AR5418+AR5133) 2GHz/5GHz 3x3:2 PCIe
AR9001-2NG (AR9160+AR9103) 2GHz 2x2:2 PCI
AR9001-3NG (AR9160+AR9103) 2GHz 3x3:2 PCI
AR9001-3NX2 (AR9160+AR9106) 2GHz/5GHz 3x3:2 PCI
AR9220 2GHz/5GHz 2x2:2 PCI
AR9223 2GHz 2x2:2 PCI
AR9280 2GHz/5GHz 2x2:2 PCIe
AR9280+AR7010 2GHz/5GHz 2x2:2 USB 2.0
AR9281 2GHz 1x2:2 PCIe
AR9285 2GHz 1x1:1 PCIe
AR9271 2GHz 1x1:1 USB 2.0
AR2427 2GHz 1x1:1 PCIe
AR9227 2GHz 2x2:2 PCI
AR9287 2GHz 2x2:2 PCIe
AR9287+AR7010 2GHz 2x2:2 USB 2.0
These are the modes the athn driver can operate in:
BSS mode Also known as infrastructure mode, this is used when asso-
ciating with an access point, through which all traffic
passes. This mode is the default.
Host AP In this mode the driver acts as an access point (base sta-
tion) for other cards.
monitor mode In this mode the driver is able to receive packets without
associating with an access point. This disables the
internal receive filter and enables the card to capture
packets from networks which it wouldn't normally have
access to, or to scan for access points.
The athn driver can be configured to use Wired Equivalent Privacy (WEP)
or Wi-Fi Protected Access (WPA-PSK and WPA2-PSK). WPA is the de facto
encryption standard for wireless networks. It is strongly recommended
that WEP not be used as the sole mechanism to secure wireless communica-
tion, due to serious weaknesses in it. The athn driver relies on the
software 802.11 stack for both encryption and decryption of data frames.
The transmit speed is user-selectable or can be adapted automatically by
the driver depending on the number of hardware transmission retries.
For USB devices, the driver needs at least version 1.1 of the following
firmware files, which are loaded when an interface is attached:
The following ifconfig.if(5) example configures athn0 to join whatever
network is available on boot, using WEP key ``0x1deadbeef1'', channel 11,
obtaining an IP address using DHCP:
dhcp NONE NONE NONE nwkey 0x1deadbeef1 chan 11
The following ifconfig.if(5) example creates a host-based access point on
inet 192.168.1.1 255.255.255.0 NONE media autoselect \
mediaopt hostap nwid my_net chan 11
Join an existing BSS network, ``my_net'':
# ifconfig athn0 192.168.1.1 netmask 0xffffff00 nwid my_net
athn%d: device timeout A frame dispatched to the hardware for transmis-
sion did not complete in time. The driver will reset the hardware. This
should not happen.
athn%d: radio is disabled by hardware switch The radio transmitter is
off and thus no packet can go out. The driver will reset the hardware.
Make sure the laptop radio switch is on.
athn%d: radio switch turned off The radio switch has been turned off
while the interface was up and running. The driver will turn the inter-
athn%d: error %d, could not read firmware %s For some reason, the driver
was unable to read the firmware file from the filesystem. The file might
be missing or corrupted.
arp(4), cardbus(4), ifmedia(4), intro(4), netintro(4), pci(4), usb(4),
The athn driver first appeared in OpenBSD 4.7. Support for USB 2.0
devices first appeared in OpenBSD 4.9. It was later ported to
The athn driver was written by Damien Bergamini <firstname.lastname@example.org>
based on source code licensed under the ISC released in 2008 by Atheros
Communications for Linux.
The athn driver does not support any of the 802.11n capabilities offered
by the adapters. Additional work is required in ieee80211(9) before
those features can be supported.
NetBSD 9.99 July 31, 2013 NetBSD 9.99