- NetBSD Manual Pages
WESC(4) NetBSD/amiga Kernel Interfaces Manual WESC(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
wesc -- Warp Engine low level SCSI interface
wesc0 at zbus0
The Amiga architecture uses a common machine independent scsi sub-system
provided in the kernel source. The machine independent drivers that use
this code access the hardware through a common interface. (see
scsibus(4)) This common interface interacts with a machine dependent
interface, such as wesc, which then handles the hardware specific issues.
The wesc interface handles things such as DMA and interrupts as well as
actually sending commands, negotiating synchronous or asynchronous trans-
fers and handling disconnect/reconnect of SCSI targets. The hardware
that wesc uses is based on the NCR53c710 SCSI chip.
The wesc interface supports the following Zorro III expansion cards:
WARP ENGINE MacroSystem Development Warp Engine internal SCSI,
manufacturer 2203, product 19
wesc%s: abort %s: dstat %02x, sstat0 %02x sbcl %02x The scsi operation
%s was aborted due to error. Dstat, sstat and sbcl are registers within
the NCR53c710 SCSI chip.
siop id %d reset The NCR53c710 SCSI chip has been reset and configure at
SIOP interrupt: %x sts %x msg %x sbcl %x The NCR53c710 SCSI chip has
SIOP: SCSI Gross Error The NCR53c710 SCSI chip has indicated that it is
SIOP: Parity Error The NCR53c710 SCSI chip has indicated that it has
detected a parity error on the SCSI bus.
The wesc interface first appeared in NetBSD 1.0
NetBSD 10.99 August 31, 1994 NetBSD 10.99