- NetBSD Manual Pages
P5PB(4) NetBSD/amiga Kernel Interfaces Manual P5PB(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
p5pb -- Phase5 PCI bridge driver
p5pb0 at p5bus0
pci* at p5pb?
genfb* at pci?
voodoofb* at pci?
The p5pb driver provides support for the PCI bus present on various
devices equipped with the Phase5 PCI bridge.
The P5PB_CONSOLE option activates the necessary support for the console
on CyberVisionPPC and BlizzardVisionPPC, allowing the attachment of the
genfb(4) driver. 3Dfx Voodoo 3 boards installed in G-REX are also sup-
ported as console by this option in conjunction with the voodoofb(4)
Additional, excessive debugging output is enabled by the P5PB_DEBUG
The p5pb driver supports the following hardware:
- Phase5 BlizzardVisionPPC graphics card
- Phase5 CyberVisionPPC graphics card
- DCE Computer G-REX 1200
- DCE Computer G-REX 4000
amiga/cv3dpb(4), amiga/p5membar(4), genfb(4), pci(4)
Programming the G-REX PCI bridge:
The p5pb device first appeared in NetBSD 6.0.
The p5pb driver was written by Radoslaw Kujawa
The NetBSD developers don't have access to G-REX hardware or documenta-
tion. Support for this device is based on best wishes.
Support for genfb(4) framebuffer on CVPPC/BVPPC needs more testing.
DMA to host memory is not supported. This is a driver limitation.
NetBSD 10.99 February 17, 2017 NetBSD 10.99