- NetBSD Manual Pages
INTRO(4) NetBSD/amiga Kernel Interfaces Manual INTRO(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
intro -- introduction to amiga special files and hardware support
This section describes the special files, related driver functions, and
networking support available in the system. In this part of the manual,
the SYNOPSIS section of each configurable device gives a sample specifi-
cation for use in constructing a system description for the config(1)
program. The DIAGNOSTICS section lists messages which may appear on the
console and/or in the system error log /var/log/messages due to errors in
device operation; see syslogd(8) for more information.
This section contains both devices which may be configured into the sys-
tem and network related information. The networking support is intro-
duced in netintro(4).
AMIGA DEVICE SUPPORT
This section describes the hardware supported on the Amiga. Software
support for these devices comes in two forms. A hardware device may be
supported with a character or block device driver, or it may be used
within the networking subsystem and have a network interface driver.
Block and character devices are accessed through files in the file system
of a special type; see mknod(8). Network interfaces are indirectly
accessed through the interprocess communication facilities provided by
the system; see socket(2).
A hardware device is identified to the system at configuration time and
the appropriate device or network interface driver is then compiled into
the system. When the resultant system is booted, the autoconfiguration
facilities in the system probe for the device and, if found, enable the
software support for it. If a device does not respond at autoconfigura-
tion time it is not accessible at any time afterwards. To enable a
device which did not autoconfigure, the system will have to be rebooted.
The autoconfiguration system is described in amiga/autoconf(4). A list
of the supported devices is given below.
The Amiga intro man page first appeared in NetBSD 1.1
LIST OF DEVICES
The devices listed below are supported in this incarnation of the system.
Devices are indicated by their functional interface. Not all supported
devices are listed.
afsc A4091 low level SCSI adapter interface
ahsc A3000 low level SCSI adapter interface
atzsc A2091 low level SCSI adapter interface
ed DP8390-based Ethernet interface
es SMC91C90-based Ethernet interface
fdc Floppy disk controller device
fd Floppy disk device
grf frame buffer for Custom Chips and graphics cards
grfcl color graphics driver for GVP Spectrum/Picasso II, II+ and
IV/Piccolo/Piccolo SD64 cards
grfcv color graphics driver for the Cybervision 64
grfcv3d color graphics driver for the Cybervision 64/3D
grfet color graphics driver for Domino/Domino16M
grful color graphics driver for the A2410
grfrh color graphics driver for Retina BLT Z3 and Altais cards
grfrt color graphics driver for the Retina Z2
gtsc GVP low level SCSI adapter interface
gvpbus GVP custom bus
kbd Amiga Keyboard device
kmem kernel virtual memory
ite Amiga Internal Terminal Emulator
ivsc IVS low level SCSI adapter interface
le AMD 7990 and AMD 79C960 Lance-based Ethernet interface
mem physical memory
mfcs MultiFaceCard II/II serial interface
mgnsc Magnum 40 low level SCSI adapter interface
otgsc 12 Gauge low level SCSI adapter interface
par 8520 built-in parallel interface
ser 8520 built-in serial interface
wesc Warp Engine low level SCSI adapter interface
wstsc Wordsync II low level SCSI adapter interface
zssc Zeus low level SCSI adapter interface
zbus Amiga Zorro II/III bus
NetBSD 10.99 February 17, 2017 NetBSD 10.99