- NetBSD Manual Pages
EM4K(4) NetBSD/amiga Kernel Interfaces Manual EM4K(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
em4k -- ELBOX Mediator 4000 PCI bridge driver
em4k0 at zbus0
emmem0 at zbus0
pci* at empb0
The em4k driver provides support for the PCI bus present on Mediator 4000
bridge and associated PCI/Zorro daughterboards.
The em4k driver supports the following hardware:
ELBOX Mediator PCI 4000D
ELBOX Mediator PCI 4000Di
ELBOX Mediator PCI 4000T
ELBOX Mediator PCI 3000D
ELBOX Mediator PCI 3000T
MK-II editions are also supported.
amiga/empb(4), amiga/mppb(4), amiga/p5pb(4), pci(4)
The em4k device first appeared in NetBSD 7.0.
The em4k driver was written by Radoslaw Kujawa
<firstname.lastname@example.org>. It was developed using information obtained
through reverse engineering by Frank Wille and Radoslaw Kujawa. The
authors have no access to official documentation (which is only available
DMA to host memory is not supported. It is unclear if the hardware sup-
ports DMA to host memory at all. It is possible to implement DMA through
bounce buffers in graphics card memory, but this needs further research.
NetBSD 9.99 February 17, 2017 NetBSD 9.99