- NetBSD Manual Pages
EST(4) NetBSD Kernel Interfaces Manual EST(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
est -- Enhanced SpeedStep
est0 at cpu0
The est driver provides support for Enhanced SpeedStep introduced in
Intel's first and second generation of Pentium M processors. The follow-
ing sysctl(8) variables are available with est:
machdep.est.frequency.target The target frequency of the CPUs.
machdep.est.frequency.current The current frequency.
machdep.est.frequency.available The frequencies recognized by est.
Note, however, that these variables are not guaranteed to exist in the
future versions of NetBSD.
acpicpu(4), x86/odcm(4), x86/powernow(4)
Intel Corporation, Intel Pentium M Processor. Datasheet,
Intel Corporation, Enhanced Intel SpeedStep Technology for the Intel
Pentium M Processor. White Paper,
The est driver is considered a legacy interface to be used only with old
systems. It is known to be problematic with new CPUs. Furthermore, in
the unlikely case where both est and x86/ichlpcib(4) or piixpcib(4) pro-
vide support for SpeedStep, the PCI-based interfaces should not be
accessed due possible race conditions.
NetBSD 9.3 February 17, 2017 NetBSD 9.3