- NetBSD Manual Pages
SOEKRIS(4) NetBSD/x86 Kernel Interfaces Manual SOEKRIS(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
soekrisgpio -- Soekris net6501 GPIO and LEDs
soekrisgpio0 at isa? port 0x680
gpio* at soekrisgpio?
The soekrisgpio driver provides support for the GPIO and LEDs as imple-
mented by the Xilinx Spartan FGPA integrated into the Soekris net6501
programmed with the default bitstream found in the BIOS.
Two standard gpio(4) interfaces are provided, one for the 16 real pins
which can be configured as either inputs or outputs and another with 2
output-only pins that map to the error and ready LEDs respectively. Both
may be used with gpioctl(8).
gpio(4), intro(4), isa(4), gpioctl(8)
The soekrisgpio driver first appeared in NetBSD 7.0.
The soekrisgpio driver was written by Matt Dainty <matt@...> and imported
from a patch for OpenBSD to NetBSD by
Frank Kardel <kardel@NetBSD.org>.
If the Xilinx FPGA is programmed with a different bitstream, the driver
will likely not function.
NetBSD 9.3 June 10, 2013 NetBSD 9.3