- NetBSD Manual Pages
RUMP_NFS(8) NetBSD System Manager's Manual RUMP_NFS(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
rump_nfs -- mount a nfs share with a userspace server
rump_nfs [options] share mountpoint
NOTE! This manual page describes features specific to the rump(3) file
server. Please see mount_nfs(8) for a full description of the available
command line options.
The rump_nfs utility can be used to mount nfs file systems. It uses
rump(3) and p2k(3) to facilitate running the file system as a server in
userspace. As opposed to mount_nfs(8), rump_nfs does not use file system
code within the kernel and therefore does not require kernel support
except puffs(4). Apart from a minor speed penalty there is no downside
with respect to in-kernel code.
Even though the rump_nfs file system client runs within a virtual rump
kernel in userspace, it uses host network services (by means of ``rump
sockin''). This means that regardless of whether using rump_nfs or
mount_nfs(8), the same network configurations will be used. Currently,
``sockin'' supports IPv4.
To use rump_nfs via mount(8), the flags -o rump and -t nfs should be
given. Similarly, rump_nfs is used instead of mount_nfs(8) if ``rump''
is added to the options field of fstab(5).
p2k(3), puffs(3), rump(3), mount_nfs(8)
The rump_nfs utility first appeared in NetBSD 5.0.
NetBSD 9.3 November 21, 2010 NetBSD 9.3