- NetBSD Manual Pages
GSCPCIB(4) NetBSD/i386 Kernel Interfaces Manual GSCPCIB(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
gscpcib -- National Semiconductor Geode SC1100 PCI-ISA bridge with GPIO
gscpcib* at pci?
isa* at gscpcib?
gpio* at gscpcib?
The gscpcib driver provides support for the National Semiconductor Geode
SC1100 System-on-Chip PCI-ISA bridge. This device is a PCI-ISA bridge,
but with some additional sub-devices. Besides the core pcib(4) function-
ality, the gscpcib driver provides support for the GPIO interface of this
The device has 64 I/O pins which can be accessed through the gpio(4)
framework. The gpioctl(8) program provides a convenient way to manipu-
late these pins from userland.
gpio(4), i386/intro(4), isa(4), pci(4), pcib(4), gpioctl(8)
The gscpcib driver first appeared in OpenBSD 3.6 and NetBSD 4.0.
The gscpcib driver was written by Alexander Yurchenko
<firstname.lastname@example.org> and was ported to NetBSD by Jared D. McNeill
NetBSD 9.3 February 17, 2017 NetBSD 9.3