- NetBSD Manual Pages
CLRI(8) NetBSD System Manager's Manual CLRI(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
clri -- clear an inode
clri special_device inode_number ...
clri is obsoleted for normal file system repair work by fsck(8).
clri zeros out the inodes with the specified inode number(s) on the
filesystem residing on the given special_device. The fsck(8) utility is
usually run after clri to reclaim the zero'ed inode(s) and the blocks
previously claimed by those inode(s). Both read and write permission are
required on the specified special_device.
The primary purpose of this routine is to remove a file which for some
reason is not being properly handled by fsck(8). Once removed, it is
anticipated that fsck(8) will be able to clean up the resulting mess.
The clri utility first appeared in Version 6 AT&T UNIX.
If the file is open, the work of clri will be lost when the inode is
written back to disk from the inode cache.
NetBSD 9.3 September 13, 2016 NetBSD 9.3