- NetBSD Manual Pages
ALE(4) NetBSD Kernel Interfaces Manual ALE(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ale -- Atheros AR8121/AR8113/AR8114 10/100/Gigabit Ethernet device
ale* at pci?
atphy* at mii?
The ale driver provides support for Ethernet interfaces based on the
Atheros AR8121/AR8113/AR8114 Ethernet chipset, also known as the Attansic
The ale driver supports IPv4 receive IP/TCP/UDP checksum offload and VLAN
tag insertion and stripping.
The following media types are supported:
autoselect Enable autoselection of the media type and options.
10baseT Set 10Mbps operation.
100baseTX Set 100Mbps (Fast Ethernet) operation.
1000baseT Set 1000Mbps (Gigabit Ethernet) operation.
For more information on configuring this device, see ifconfig(8). To
view a list of media types and options supported by the card, try
ifconfig -m <device>. For example, ifconfig -m ale0.
arp(4), atphy(4), ifmedia(4), intro(4), netintro(4), pci(4), ifconfig(8)
The ale device driver first appeared in OpenBSD 4.5. It was then ported
to NetBSD 5.1.
The ale driver was written by Pyun YongHyeon for FreeBSD and ported to
OpenBSD by Kevin Lo <kevlo@OpenBSD.org> then ported to NetBSD by
Christoph Egger <cegger@NetBSD.org> and Kevin Lahey.
NetBSD 9.3 May 5, 2009 NetBSD 9.3