- NetBSD Manual Pages
PAM_SECURETTY(8) NetBSD System Manager's Manual PAM_SECURETTY(8)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
pam_securetty -- SecureTTY PAM module
[service-name] module-type control-flag pam_securetty [options]
The SecureTTY service module for PAM provides functionality for only one
PAM category: account management. In terms of the module-type parameter,
this is the ``account'' feature. It also provides null functions for
authentication and session management.
SecureTTY Account Management Module
The SecureTTY account management component (pam_sm_acct_mgmt()), returns
failure if the user is attempting to authenticate as superuser, and the
process is attached to an insecure TTY. In all other cases, the module
A TTY is considered secure if it is listed in /etc/ttys and has the
TTY_SECURE flag set.
The following options may be passed to the authentication module:
debug syslog(3) debugging information at LOG_DEBUG level.
no_warn suppress warning messages to the user. These messages include
reasons why the user's authentication attempt was declined.
getttynam(3), syslog(3), pam.conf(5), ttys(5), pam(8)
NetBSD 9.2 July 8, 2001 NetBSD 9.2