- NetBSD Manual Pages
MPL115A(4) NetBSD Kernel Interfaces Manual MPL115A(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
mpl115a -- Freescale MPL115A2 absolute pressure sensor driver
mpl115a* at iic? addr 0x60
The mpl115a driver provides support for the MPL115A2 pressure sensor. It
allows reporting absolute pressure through the envsys(4) API.
The mpl115a device first appeared in NetBSD 7.0.
The mpl115a driver was written by Radoslaw Kujawa
<firstname.lastname@example.org>. The fixed-point pressure calculation algo-
rithm was suggested by Matt Thomas.
The MPL115A2 chip has an accuracy of +/- 1 kPa, which makes it not very
useful for weather-related applications.
The envsys(4) API does not support pressure reporting yet, so the result
is reported just as integer number.
NetBSD 9.2 September 8, 2013 NetBSD 9.2