- NetBSD Manual Pages
LD.SO.CONF(5) NetBSD File Formats Manual LD.SO.CONF(5)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
ld.so.conf -- run-time link-editor configuration file
The ld.so.conf file specifies additional default directories (beyond the
standard set, normally ``/usr/lib'').
On a.out(5) systems, this file is scanned by ldconfig(8) to create the
hints files used by the run-time linker /usr/libexec/ld.so to locate
On elf(5) systems, this file is scanned directly by the run-time linker
Lines beginning with `#' are treated as comments and ignored. Any other
non-blank lines beginning with `/' are stripped of leading whitespace and
trailing comments (introduced with `#') together with any preceding
whitespace, then treated as directories to be scanned for shared
libraries to add to the hints.
On elf(5) lines that do not begin with a `/' are parsed as hardware
dependent per library directives:
<library> <sysctl> <variable>[,...]:<library>[,...] ...
If there is no match, the standard action is taken.
libm.so.0 machdep.fpu_present 1:libm387.so.0,libm.so.0
The above line loads both libm387 and libm when the sysctl(3) variable
fpu_present has the value 1.
ld.aout_so(1), ld.elf_so(1), a.out(5), elf(5), ldconfig(8)
The ld.so.conf file appeared in NetBSD 1.3. The ELF support for it was
added in NetBSD 1.5.
Directory names containing the comment character (`#') and/or leading or
trailing whitespace cannot be included. (Embedded blanks are allowed,
NetBSD 9.2 July 21, 2004 NetBSD 9.2