- NetBSD Manual Pages
ITIMERFIX(9) NetBSD Kernel Developer's Manual ITIMERFIX(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
itimerfix -- check that a timeval value is valid, and correct
itimerfix(struct timeval *tv);
The itimerfix function checks that the value in tv is valid (0 <=
tv->tv_sec && 0 <= tv->tv_usec < 1000000), and that the total time rep-
resented is at least one tick, or zero.
If the total represented time is nonzero and smaller than tick, it is
adjusted to exactly one tick.
itimerfix returns 0 on success or EINVAL if tv is invalid.
nanosleep(2), poll(2), select(2), setitimer(2)
NetBSD 9.2 November 23, 2001 NetBSD 9.2