- NetBSD Manual Pages
DELAY(9) NetBSD Kernel Developer's Manual DELAY(9)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
delay, DELAY -- microsecond delay
delay(unsigned int us);
DELAY(unsigned int us);
Wait approximately us microseconds.
The delay is implemented as a machine loop, preventing events other than
interrupt handlers for unmasked interrupts to run. DELAY() is reentrant
(doesn't modify any global kernel or machine state) and is safe to use in
interrupt or process context.
For long delays, condition variables should be considered, however they
can only be used from process context and their resolution is limited by
the system clock frequency.
condvar(9), hz(9), kpause(9)
NetBSD 9.2 July 20, 2011 NetBSD 9.2