- NetBSD Manual Pages
GPIOSIM(4) NetBSD Kernel Interfaces Manual GPIOSIM(4)
Powered by man-cgi (2021-03-02).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
gpiosim -- General Purpose Input/Output Simulator
The gpiosim pseudo-device simulates a 64-bit wide gpio(4) device. The
state of the simulated device can be manipulated through the sysctl(8)
interface. For this purpose, access the "hw.gpiosim<N>.value" sysctl(8)
variable, where "<N>" denotes the number of the gpiosim instance.
The gpiosim driver was written by Marc Balmer <email@example.com>.
NetBSD 9.1 May 20, 2013 NetBSD 9.1