- NetBSD Manual Pages
INTRO(4) NetBSD/mac68k Kernel Interfaces Manual INTRO(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
intro -- introduction to mac68k special files and hardware support
This section describes the special files, related driver functions, and
networking support available in the system. In this part of the manual,
the SYNOPSIS section of each configurable device gives a sample specifi-
cation for use in constructing a system description for the config(1)
program. The DIAGNOSTICS section lists messages which may appear on the
console and/or in the system error log /var/log/messages due to errors in
device operation; see syslogd(8) for more information.
This section contains both devices which may be configured into the sys-
tem and network related information. The networking support is intro-
duced in netintro(4).
MAC68K DEVICE SUPPORT
This section describes the hardware supported on the Mac. Software sup-
port for these devices comes in two forms. A hardware device may be sup-
ported with a character or block device driver, or it may be used within
the networking subsystem and have a network interface driver. Block and
character devices are accessed through files in the file system of a spe-
cial type; see mknod(8). Network interfaces are indirectly accessed
through the interprocess communication facilities provided by the system;
A hardware device is identified to the system at configuration time and
the appropriate device or network interface driver is then compiled into
the system. When the resultant system is booted, the autoconfiguration
facilities in the system probe for the device and, if found, enable the
software support for it. If a device does not respond at autoconfigura-
tion time it is not accessible at any time afterwards. To enable a
device which did not autoconfigure, the system will have to be rebooted.
The autoconfiguration system is described in mac68k/autoconf(4). A list
of the supported devices is given below.
The Mac68k intro man page first appeared in NetBSD 1.3.
LIST OF DEVICES
The devices listed below are supported in this incarnation of the system.
Devices are indicated by their functional interface. Not all supported
devices are listed.
adb Apple Desktop Bus event interface
ae DP8390-based Ethernet interface
asc Apple Sound Chip
esp NCR 53C9x built-in SCSI interface
grf on-board and NuBus-based video interface
kmem kernel virtual memory
ite Mac68k Internal Terminal Emulator
mem physical memory
NCR 5380 built-in SCSI interface
sbc NCR 5380 built-in SCSI interface
sn DP83932-based Ethernet interface (SONIC)
zsc Zilog Z8530 built-in serial interface
NetBSD 9.0 February 17, 2017 NetBSD 9.0