- NetBSD Manual Pages
VIRT(4) NetBSD Kernel Interfaces Manual VIRT(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
virt -- rump kernel virtual network interface
The virt interface acts as a link between a rump kernel and a host tap(4)
interface. Interface number <n> always corresponds with the host tap
interface tap<n>. All data sent by virt is written into /dev/tap<n> and
all data read from /dev/tap<n> is passed as Ethernet input to the rump
A virt interface can be created and destroyed in the normal fashion with
The host's tap(4) interface can be further bridged with hardware inter-
faces to provide full Internet access to a rump kernel.
rump(3), bridge(4), tap(4), brconfig(8), ifconfig(8)
NetBSD 7.0 July 3, 2013 NetBSD 7.0