- NetBSD Manual Pages
VIORND(4) NetBSD Kernel Interfaces Manual VIORND(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
viornd -- VirtIO entropy source
viornd* at virtio?
When the system has entropy demand, the viornd driver, used with a com-
patible hypervisor such as QEMU, KVM, or Google Compute Engine, requests
entropy using the VirtIO random number interface and feeds it into the
system entropy pool.
The viornd driver appeared in OpenBSD 5.5.
The viornd driver was written by Stephan Fritsch <email@example.com> and
reworked to request entropy upon demand by
Thor Lancelot Simon <tls@NetBSD.org>.
VirtIO appears to support at least 8 pending entropy requests, but viornd
currently supports only one pending request at a time.
NetBSD 7.0 October 26, 2014 NetBSD 7.0