- NetBSD Manual Pages
VMT(4) NetBSD/x86 Kernel Interfaces Manual VMT(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
vmt -- VMware Tools driver
vmt0 at cpufeaturebus*
The vmt driver is a kernel level implementation of VMware Tools. VMware
Tools are intended to provide better support for operating systems run-
ning inside virtual machines.
vmt handles shutdown, reboot, resume requests from the host by sending
events using sysmon_pswitch(9) of type PSWITCH_TYPE_POWER,
PSWITCH_TYPE_RESET, and PSWITCH_TYPE_SLEEP that can be handled by
powerd(8). vmt will log notifications that the guest has been suspended
or resumed by the host.
vmt reports the guest's hostname and first non-loopback IP address to the
The vmt driver first appeared in OpenBSD 4.4 and was then ported to
The vmt driver was written by David Gwynne <email@example.com>.
NetBSD 6.0 October 18, 2011 NetBSD 6.0