- NetBSD Manual Pages
VIRTIO(4) NetBSD Kernel Interfaces Manual VIRTIO(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
virtio -- Para-virtualized I/O in a virtual machine
virtio* at pci? dev ? function ?
ld* at virtio?
vioif* at virtio?
viomb* at virtio?
virtio defines an interface for efficient, standard and extensible I/O
between the hypervisor and the virtual machine. The virtio device driver
represents an emulated PCI device that the hypervisor makes available to
the virtual machine.
virtio driver itself provides the core infrastructure to communicate with
the hypervisor (called virtqueues) and supports the following devices:
ld(4) A Disk device.
An Ethernet device.
A pseudo-device to release memory back to the hypervisor.
ld(4), pci(4), vioif(4), viomb(4)
Rusty Russell, IBM Corporation, Virtio PCI Card Specification,
The virtio driver first appeared in NetBSD 6.0.
NetBSD 6.0 November 5, 2011 NetBSD 6.0