- NetBSD Manual Pages
CAS(4) NetBSD Kernel Interfaces Manual CAS(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
cas -- Cassini/Cassini+ (GigaSwift) Ethernet device driver
cas* at pci? dev ? function ?
Configuration of PHYs may also be necessary. See mii(4).
The cas driver provides support for the Sun Cassini and Cassini+
(GigaSwift) and the National Semiconductor Saturn Ethernet hardware found
in Sun UltraSPARC machines and Sun GigaSwift PCI cards.
Cards supported by this driver include:
· Sun Gigaswift Ethernet (SX fibre variants)
· Sun Gigaswift Ethernet (UTP variants)
· Sun quad Gigaswift Ethernet
brgphy(4), gentbi(4), gphyter(4), ifmedia(4), intro(4), mii(4),
Sun Microsystems, Cassini+ ASIC Specification,
The cas driver first appeared in OpenBSD 4.1. NetBSD support was added
in NetBSD 6.0.
The cas driver was written for OpenBSD by Mark Kettenis
<email@example.com>, based on the gem(4) driver, and ported to NetBSD
by Julian Coleman <jdc@NetBSD.org>.
The cas driver does not support any of the advanced features of the
On the SX fibre variants of the hardware, the link may stay down if media
options apart from autoselect are chosen.
NetBSD 6.0 January 7, 2010 NetBSD 6.0