grf(4) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
GRF(4)               NetBSD/hp300 Kernel Interfaces Manual              GRF(4)


NAME
grf -- HP graphics frame buffer device interface
SYNOPSIS
grf* at dvbox? grf* at gbox? grf* at hyper? grf* at rbox? grf* at topcat?
DESCRIPTION
This is a generic description of the frame buffer device interface. The devices to which this applies are the 98544, 98545 and 98547 Topcat dis- play cards (also known as HP300H devices), the 98548, 98549 and 98550 Catseye display cards, the 98700 Gatorbox graphics box, the 98720 Renais- sance graphics box, and the 98730 DaVinci graphics box. Use of the devices can be effectively approached from two directions. The first is through HP-UX Starbase routines, the second is by direct control in the BSD environment. In order to use the Starbase libraries, code must be compiled in an HP-UX environment, either by doing so on an HP-UX machine and transferring the binaries to the BSD machine, or by compilation with the use of the hpux command. Applications using Star- base libraries have been run successfully on BSD machines using both of these compilation techniques. Direct compilation, such as that used for the X Window System servers, has also been successful. Examples of some frame buffer operations can be found in the device dependent X Window system sources, for example the /usr/src/new/X/libhp.fb directory. These files contain examples of device dependent color map initialization, frame buffer operations, bit moving routines etc. The basic programming of the grf? devices involves opening the device file, mapping the control registers and frame buffer addresses into user space, and then manipulating the device as the application requires. The address mapping is controlled by an ioctl(2) call to map the device into user space, and an unmap call when finished. The ioctls supported by BSD are: GRFIOCGINFO Get Graphics Info Get info about device, setting the entries in the grfinfo struc- ture, as defined in <hpdev/grfioctl.h>: struct grfinfo { int gd_id; /* HPUX identifier */ caddr_t gd_regaddr; /* control registers physaddr */ int gd_regsize; /* control registers size */ caddr_t gd_fbaddr; /* frame buffer physaddr */ int gd_fbsize; /* frame buffer size */ short gd_colors; /* number of colors */ short gd_planes; /* number of planes */ /* new stuff */ int gd_fbwidth; /* frame buffer width */ int gd_fbheight; /* frame buffer height */ int gd_dwidth; /* displayed part width */ int gd_dheight; /* displayed part height */ int gd_pad[6]; /* for future expansion */ }; GRFIOCON Graphics On Turn graphics on by enabling CRT output. The screen will come on, displaying whatever is in the frame buffer, using whatever colormap is in place. GRFIOCOFF Graphics Off Turn graphics off by disabling output to the CRT. The frame buffer contents are not affected. GRFIOCMAP Map Device to user space Map in control registers and framebuffer space. Once the device file is mapped, the frame buffer structure is accessible. GRFIOCUNMAP Unmap Device Unmap control registers and framebuffer space. For further information about the use of ioctl see the man page.
FILES
/dev/grf? BSD interface special files /dev/*crt* HP-UX starbase interface special files
EXAMPLES
This short code fragment is an example of opening some graphics device and mapping in the control and frame buffer space: #define GRF_DEV <some_graphics_device> /* /dev/grfN */ { struct fbstruct *regs; /* fbstruct = gboxfb, rboxfb, etc. */ u_char *Addr, frame_buffer; struct grfinfo gi; int disp_fd; disp_fd = open(GRF_DEV,1); if (ioctl (disp_fd, GRFIOCGINFO, &gi) < 0) return -1; (void) ioctl (disp_fd, GRFIOCON, 0); Addr = (u_char *) 0; if (ioctl (disp_fd, GRFIOCMAP, &Addr) < 0) { (void) ioctl (disp_fd, GRFIOCOFF, 0); return -1; } regs = (fbstruct *) Addr; /* Control Registers */ frame_buffer = (u_char *) Addr + gi.gd_regsize; /* Frame buffer mem */ }
DIAGNOSTICS
None under BSD. HP-UX The CE.utilities/Crtadjust programs must be used for each specific device.
ERRORS
[ENODEV] no such device. [EBUSY] Another process has the device open. [EINVAL] Invalid ioctl specification.
SEE ALSO
ioctl(2), dvbox(4), gbox(4), hil(4), hyper(4), rbox(4), topcat(4) NetBSD 5.0 September 10, 2001 NetBSD 5.0
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.