- NetBSD Manual Pages
SERVICES(5) NetBSD File Formats Manual SERVICES(5)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
services -- service name data base
The services file contains information regarding the known services
available in the DARPA Internet. For each service a single line should
be present with the following information:
official service name
Items are separated by any number of blanks and/or tab characters. The
port number and protocol name are considered a single item; a slash
(``/'') is used to separate the port and protocol (e.g. ``512/tcp''). A
hash (``#'') indicates the beginning of a comment; subsequent characters
up to the end of the line are not interpreted by the routines which
search the file.
Service names may contain any printable character other than a field
delimiter, newline, or comment character.
The database in /var/db/services.db needs to be updated with
services_mkdb(8) after changes to the services file have been applied.
/etc/services The services file resides in /etc.
The services file format appeared in 4.2BSD.
A name server should be used instead of a static file.
NetBSD 5.0.1 June 19, 2007 NetBSD 5.0.1