- NetBSD Manual Pages
RUMP_SYSVBFS(8) NetBSD System Manager's Manual RUMP_SYSVBFS(8)
Powered by man-cgi (2021-03-02).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
rump_sysvbfs -- mount the sysvbfs file system using a userspace server
rump_sysvbfs [options] special node
The rump_sysvbfs utility can be used to mount sysvbfs file systems. It
uses rump(3) and p2k(3) to facilitate running the file system as a server
in userspace. As opposed to mount_sysvbfs(8), rump_sysvbfs does not use
file system code within the kernel and therefore does not require kernel
support except puffs(4). Apart from a minor speed penalty (starting from
10% and depending on the workload and file system in question), there is
no difference to using in-kernel code.
In case mounting a file system image from a regular file, rump_sysvbfs
does not require the use of vnconfig(8) unlike kernel file systems.
Instead, the image path can be directly passed as the special file path.
The exception is if the image contains a disklabel. In this case vncon-
fig is required to resolve the start offset for the correct partition
within the image.
It is recommended that untrusted file system images be mounted with
rump_sysvbfs instead of mount_sysvbfs(8). Corrupt file system images
commonly cause the file system to crash the entire kernel, but with
rump_sysvbfs only the userspace server process will dump core.
To use rump_sysvbfs via mount(8), the flags -o rump and -t sysvbfs should
be given. Similarly, rump_sysvbfs is run instead of mount_sysvbfs(8) if
``rump'' is added to the options field of fstab(5).
Please see mount_sysvbfs(8) for a full description of the available com-
mand line options.
p2k(3), puffs(3), rump(3), mount_sysvbfs(8)
The rump_sysvbfs utility first appeared in NetBSD 5.0. It is currently
NetBSD 5.0.1 February 15, 2009 NetBSD 5.0.1