- NetBSD Manual Pages
RELEASE(7) NetBSD Miscellaneous Information Manual RELEASE(7)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
release -- layout of NetBSD releases and snapshots
This document describes the layout of NetBSD releases and snapshots.
This layout should be consistent between FTP servers and CD-ROMs, except
possibly the path that leads to the release hierarchy.
In this document, the following special words have these definitions:
<machine> The platform for which the release was built, correspond-
ing to the hw.machine sysctl variable, e.g. i386 or
<machine_arch> The architecture for which a particular installation set
was built, corresponding to the hw.machine_arch sysctl
variable, e.g. i386 or m68k.
<rel> The target release.
All README files are descriptions of the various files in directories
that have ``non-standard'' contents. There may also be a README file at
the top-level, describing who built the snapshot and under what circum-
stances (e.g. whether it's an official NetBSD snapshot, or not).
All BSDSUM files are historic BSD checksums for the various files in that
directory, in the format produced by the command: cksum -o 1 <file>.
All CKSUM files are POSIX checksums for the various files in that direc-
tory, in the format produced by the command: cksum <file>.
All MD5 files are MD5 digests for the various files in that directory, in
the format produced by the command: cksum -m <file>.
All SYSVSUM files are historic AT&T System V UNIX checksums for the vari-
ous files in that directory, in the format produced by the command: cksum
-o 2 <file>.
The MD5 digest is the safest checksum, followed by the POSIX checksum.
The other two checksums are provided only to ensure that the widest pos-
sible range of system can check the integrity of the release files.
Files that end in .tgz are gzipped tar archives. This is used in lieu of
.tar.gz because the software used to download the sets may incorrectly
auto-unpack files ending in .gz and to accommodate systems which only
support 3 character extensions to file names.
All tar archives are relative to the target's / directory, and do not
include the leading ``/''.
All compression of release files is to be performed with the command:
The root of the release hierarchy may be the root directory of a CD-ROM,
but in all other cases it should be .../NetBSD-<rel>/.
The root of the release hierarchy should contain the following files and
A file containing the date, in UTC, of the source code from
which the release or snapshot was built, in the default format
produced by the command: date -u.
iso/ CDROM images in ISO 9660 format, usually created with
``./build.sh ... iso-image ...'' after a ``./build.sh -x ...
release ...'' in src or created with ``./build.sh ...
iso-image-source ...'' after a ``./build.sh -x ... release
sourcesets ...'' in src.
Images in this directory, unlike images in the
should contain file systems that have an internal layout that
corresponds to a complete release for one or more machine
types. If built with ``iso-image-source'', then it will also
contain a ``source'' directory. These images are usually
shared/ Files shared by two or more machine types.
Files which may be shared by all systems of
the same <machine_arch> will be located in
symbolic links pointing to these files from
the <machine> subdirectory.
ALL/ Files which are completely machine-independent
will be located in
.../NetBSD-<rel>/shared/ALL/ with symbolic
links pointing to these files from the
source/ Source codes of the operating system and patches for it should
be put into .../NetBSD-<rel>/source/ using the following lay-
patches/ This directory contains various patch files appro-
priate for patch(1). Other patches may exist for
fixing critical problems.
Diff against the last
release, usually generated
by cvs rdiff. For patch
releases, diffs against the
last release are included.
If the last release was a
patch release itself, the
diff is against that patch
release is included.
sets/ Sources for the various system sets, based on their
modules in the CVS server.
gnusrc.tgz Contains sources for all GPLed and
possibly other programs that contains
restrictions in their licensing that
prevent others from using these pro-
grams in closed-source environments.
pkgsrc.tgz Package-sources for third party soft-
ware ready to compile. See
pkgsrc/README for more information.
sharesrc.tgz Contains machine-independent data
files that can be shared across archi-
src.tgz The operating system's userland source
code, including all programs, tools,
syssrc.tgz Kernel sources for all architectures
plus sources of the tools needed to
build kernels (like config(1)).
xsrc.tgz Source code of the X Window System
used on all NetBSD architectures.
Includes X clients and servers.
The binary releases in .../NetBSD-<rel>/<machine>/ follow the
INSTALL.txt Installation notes, including complete descrip-
tions of files contained within the release
INSTALL.more pretty version of this, suited for viewing with
INSTALL.html HTML version of this
INSTALL.ps PostScript version of this
binary/ system binaries
sets/ installation sets
base.tgz The base binary distri-
bution. This set con-
tains the base NetBSD
utilities that are nec-
essary for the system
to run and be minimally
libraries for those
architectures that sup-
port them. This set
excludes all things
listed in the sets
comp.tgz The compiler tools dis-
tribution. This set
contains the C and C++
linker, other toolchain
components, and their
manual pages. It also
includes the system
(/usr/include) , and
the static system
etc.tgz This set contains the
files that reside in
/etc and in several
other places throughout
the file system hierar-
games.tgz This set includes the
games and their manual
kern.tgz This set includes a
man.tgz This set includes all
of the manual pages for
the binaries and other
software contained in
the base set which are
not included in the
misc.tgz This set includes the
(which are rather
large), the typeset-
table document set, and
manual pages for other
happen to be installed
from the source tree by
text.tgz This set includes the
NetBSD text processing
groff(1), all related
programs, and their
xbase.tgz This set includes the
base X11 distribution,
including manual pages
and shared libraries
for those architectures
that support them, and
contained in the other
xcomp.tgz This set includes the
X11 include files and
static X11 libraries.
xcontrib.tgz This set includes bina-
ries and manual pages
for programs built from
the X11 ``contrib''
xfont.tgz This set includes the
xserver.tgz This set includes the X
servers and manual
pages for <machine>.
Note: this set may not
be available on some
kernel/ suitably named, gzipped kernels
netbsd-GENERIC.gz A kernel built
from the GENERIC
tion file. This
is meant as an
example only; dif-
may have differ-
ently named ker-
installation/ installation helper items
cdrom/ CDROM images in ISO 9660 format,
usually created as part of
``build.sh ... release ...'' in
Images in this directory will typi-
cally be bootable, and will contain
one or more of a kernel, installa-
tion tools, and rescue tools. They
will not contain installation sets,
source sets, or other components of
a complete release.
diskimage/ disk images, for those platforms
that provide them
floppy/ floppy images, for those platforms
that provide them
miniroot/ miniroot images, for those plat-
forms that provide them
misc/ miscellaneous installation helper
utilities, including boot selec-
tors, floppy writing software,
other software that runs under for-
eign operating systems, etc.
netboot/ network boot programs
tapeimage/ tape images, for those platforms
that provide them
cksum(1), date(1), gzip(1), split(1), tar(1)
The release manual page first appeared in NetBSD 1.3.
NetBSD 5.0.1 August 30, 2007 NetBSD 5.0.1