- NetBSD Manual Pages
CLNP(4) NetBSD Kernel Interfaces Manual CLNP(4)
Powered by man-cgi (2020-09-24).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
clnp -- Connectionless-Mode Network Protocol
socket(AF_ISO, SOCK_RAW, 0);
CLNP is the connectionless-mode network protocol used by the connection-
less-mode network service. This protocol is specified in ISO 8473. It
may be accessed through a ``raw socket'' for debugging purposes only.
CLNP sockets are connectionless, and are normally used with the sendto(2)
and recvfrom(2) system calls, though the connect(2) call may also be used
to fix the destination for future packets (in which case the read(2) or
recv(2) and write(2) or send(2) system calls may be used).
Outgoing packets automatically have a CLNP header prepended to them.
Incoming packets received by the user contain the full CLNP header. The
following setsockopt(2) options apply to CLNP:
CLNPOPT_FLAGS Sets the flags which are passed to clnp when sending a
datagram. Valid flags are:
CLNP_NO_SEG Do not allow segmentation
CLNP_NO_ER Suppress ER pdus
CLNP_NO_CKSUM Do not generate the CLNP checksum
CLNPOPT_OPTS Sets CLNP options. The options must be formatted exactly
as specified by ISO 8473, section 7.5 ``Options Part''.
Once an option has been set, it will be sent on all pack-
ets until a different option is set.
CONGESTION EXPERIENCE BIT
Whenever a packet is transmitted, the globally unique quality of service
option is added to the packet. The sequencing preferred bit and the low
transit delay bit are set in this option.
If a packet is forwarded containing the globally unique quality of ser-
vice option, and the interface through which the packet will be transmit-
ted has a queue length greater than congest_threshold, then the conges-
tion experienced bit is set in the quality of service option.
The threshold value stored in congest_threshold may be tuned.
When a packet is received with the globally unique quality of service
option present, and the congestion experienced bit is set, then the
transport congestion control function is called.
A socket operation may fail with one of the following errors returned:
[EISCONN] When trying to establish a connection on a socket which
already has one, or when trying to send a datagram with
the destination address specified and the socket is
[ENOTCONN] When trying to send a datagram, but no destination
address is specified, and the socket hasn't been con-
[ENOBUFS] When the system runs out of memory for an internal data
[EADDRNOTAVAIL] When an attempt is made to create a socket with a net-
work address for which no network interface exists;
[EHOSTUNREACH] When trying to send a datagram, but no route to the des-
tination address exists.
[EINVAL] When specifying unsupported options.
recv(2), send(2), intro(4), iso(4)
Packets are sent with the type code of 0x1d (technically an invalid
packet type) for lack of a better way to identify raw CLNP packets.
No more than MLEN bytes of options can be specified.
NetBSD 5.0.1 April 2, 1994 NetBSD 5.0.1