- NetBSD Manual Pages
AAC(4) NetBSD Kernel Interfaces Manual AAC(4)
Powered by man-cgi (2021-03-02).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
aac -- Adaptec AdvancedRAID Controller driver
aac* at pci? dev ? function ?
ld* at aac? unit ?
The aac driver provides support for the Adaptec AAC family of SCSI and
SATA RAID controllers. These controllers support RAID 0, 1, 5, 10, and
volume sets. They have four channels in the add-in version or 1-2 chan-
nels in the motherboard integrated version, and are most often found
rebadged by Dell, Hewlett-Packard or IBM. Supported controllers include:
· Adaptec AAC-364
· Adaptec SCSI RAID 2120S
· Adaptec SCSI RAID 2200S
· Adaptec SATA RAID 2410SA
· Adaptec SCSI RAID 5400S
· Dell PERC 2/Si
· Dell PERC 2/QC
· Dell PERC 3/Di
· Dell PERC 3/Si
· Dell PERC 320/DC
· Dell CERC SATA RAID 1.5/6ch
· HP NetRAID 4M
· HP ML110 G2 (Adaptec SATA RAID 2610SA)
· IBM ServeRAID 8k
Access to RAID containers is available via the ld device driver. Indi-
vidual drives cannot be accessed unless they are part of a container or
volume set, and non-fixed disks cannot be accessed. Containers can be
configured by using the on-board BIOS utility of the card.
The adapter can send status and alert messages asynchronously to the
driver. These messages are printed on the system console.
The aac driver first appeared in NetBSD 1.6, and was based on the FreeBSD
driver of the same name.
This driver is not compatible with controllers that have version 1.x
firmware. The firmware version is the same as the kernel version printed
in the BIOS POST and driver attach messages.
NetBSD 5.0.1 March 10, 2007 NetBSD 5.0.1