- NetBSD Manual Pages
IT(4) NetBSD Kernel Interfaces Manual IT(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
it -- ITE IT8705F, IT8712F and SiS950 hardware monitors
it0 at isa? port 0x290
The it driver provides support for the IT8705F, IT8712F and SiS950 hard-
ware monitors to be used with the envsys(4) interface.
The it driver has 9 sensors:
Sensor Units Typical Use
Fan0 RPM CPU Fan
Fan1 RPM System Fan
VIN0 uV DC Core voltage
VIN2 uV DC +3.3V
VIN3 uV DC +5V
VIN4 uV DC +12V
VBAT uV DC VBAT
Temp uK CPU Temperature
Temp uK System Temperature
By default the it driver uses the port address 0x290 but another manufac-
turers are known to use 0xc00 or 0xd00 port addresses.
The it driver first appeared in OpenBSD 3.4 and then it was ported to
The it driver was written by Julien Bordet <firstname.lastname@example.org> and was
ported to NetBSD by Juan Romero Pardines <email@example.com>.
Interrupt support is unimplemented.
NetBSD 4.0 January 7, 2006 NetBSD 4.0