autoconf(9) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
AUTOCONF(9)            NetBSD Kernel Developer's Manual            AUTOCONF(9)


NAME
autoconf, config_search, config_found_sm, config_found, config_match, config_attach, config_detach, config_activate, config_deactivate, config_defer, config_interrupts, config_pending_incr, config_pending_decr -- autoconfiguration framework
SYNOPSIS
#include <sys/param.h> #include <sys/device.h> #include <sys/errno.h> struct cfdata * config_search(cfmatch_t func, struct device *parent, void *aux); struct device * config_found_sm(struct device *parent, void *aux, cfprint_t print, cfmatch_t submatch); struct device * config_found(struct device *parent, void *aux, cfprint_t print); int config_match(struct device *parent, struct cfdata *cf, void *aux); struct device * config_attach(struct device *parent, struct cfdata *cf, void *aux, cfprint_t print); int config_detach(struct device *dev, int flags); int config_activate(struct device *dev); int config_deactivate(struct device *dev); int config_defer(struct device *dev, void (*func)(struct device *)); void config_interrupts(struct device *dev, void (*func)(struct device *)); void config_pending_incr(); void config_pending_decr();
DESCRIPTION
Autoconfiguration is the process of matching hardware devices with an appropriate device driver. In its most basic form, autoconfiguration consists of the recursive process of finding and attaching all devices on a bus, including other busses. The autoconfiguration framework supports direct configuration where the bus driver can determine the devices present. The autoconfiguration framework also supports indirect configuration where the drivers must probe the bus looking for the presence of a device. Direct configuration is preferred since it can find hardware regardless of the presence of proper drivers. The autoconfiguration process occurs at system bootstrap and is driven by a table generated from a ``machine description'' file by config(8). For a description of the config(8) ``device definition'' language, see config(9). Each device must have a name consisting of an alphanumeric string that ends with a unit number. The unit number identifies an instance of the driver. Device data structures are allocated dynamically during autocon- figuration, giving a unique address for each instance.
FUNCTIONS
config_search(func, parent, aux) Performs indirect configuration of physical devices. config_search() iterates over all potential children, calling the given function func for each one. If func is NULL, config_search() applies each child's match function instead. The argument parent is the pointer to the parent's device struc- ture. The given aux argument describes the device that has been found and is simply passed on through func to the child. config_search() returns a pointer to the best-matched child or NULL otherwise. The role of func is to call the match function for each device and call config_attach() for any positive matches. If func is NULL, then the parent should record the return value from config_search() and call config_attach() itself. Note that this function is designed so that it can be used to apply an arbitrary function to all potential children. In this case callers may choose to ignore the return value. config_found_sm(parent, aux, print, submatch) Performs direct configuration on a physical device. config_found_sm() is called by the parent and in turn calls the submatch function to call the match function as determined by the configuration table. If submatch is NULL, the driver match functions are called directly. The argument parent is the pointer to the parent's device structure. The given aux argu- ment describes the device that has been found. The softc struc- ture for the matched device will be allocated, and the appropri- ate driver attach function will be called. If the device is matched, the system prints the name of the child and parent devices, and then calls the print function to produce additional information if desired. If no driver takes a match, the same print function is called to complain. The print function is called with the aux argument and, if the matches failed, the full name (including unit number) of the parent device, other- wise NULL. The print function must return an integer value. Two special strings, ``not configured'' and ``unsupported'' will be appended automatically to non-driver reports if the return value is UNCONF or UNSUPP respectively; otherwise the function should return the value QUIET. config_found_sm() returns a pointer to the attached device's softc structure if the device is attached, NULL otherwise. Most callers can ignore this value, since the system will already have printed a diagnostic. config_found(parent, aux, print) This function is equivalent to calling config_found_sm(parent, aux, print, submatch) with submatch set to NULL and is provided for compatibility with older drivers. config_match(parent, cf, aux) Match a device. Invokes the drivers match function according to the configuration table. The config_match() function returns a nonzero integer indicating the confidence of supporting this device and a value of 0 if the driver doesn't support the device. config_attach(parent, cf, aux, print) Attach a found device. Allocates the memory for the softc structure and calls the drivers attach function according to the configuration table. If successful, config_attach() returns the softc. If unsuccessful, it returns NULL. config_detach(dev, flags) Called by the parent to detach the child device. The second argument flags contains detachment flags. Valid values are DETACH_FORCE (force detachment (e.g., because of hardware removal)) and DETACH_QUIET (do not print a notice). config_detach() returns zero if successful and an error code otherwise. config_detach() is always called from a thread con- text, allowing ltsleep(9) to be called while the device detaches itself. config_activate(dev) Called by the parent to activate the child device dev. It is called to activate resources and initialise other kernel subsys- tems (such as the network subsystem). config_activate() is called from interrupt context after the device has been attached. config_deactivate(dev) Called by the parent to deactivate the child device dev. config_deactivate() is called from interrupt context to immedi- ately relinquish resources and notify dependent kernel subsys- tems that the device is about to be detached. At some later point config_detach() will be called to finalise the removal of the device. config_defer(dev, func) Called by the child to defer the remainder of its configuration until all its parent's devices have been attached. At this point, the function func is called with the argument dev. config_interrupts(struct device *dev, void (*func)(struct device *)) Called by the child to defer the remainder of its configuration until interrupts are enabled. At this point, the function func is called with the argument dev. config_pending_incr() Increment the config_pending semaphore. It is used to account for deferred configurations before mounting the root file sys- tem. config_pending_decr() Decrement the config_pending semaphore. It is used to account for deferred configurations before mounting the root file sys- tem.
CODE REFERENCES
This section describes places within the NetBSD source tree where actual code implementing or using the autoconfiguration framework can be found. All pathnames are relative to /usr/src. The autoconfiguration framework itself is implemented within the file sys/kern/subr_autoconf.c. Data structures and function prototypes for the framework are located in sys/sys/device.h.
SEE ALSO
config(8), config(9), driver(9)
HISTORY
Autoconfiguration first appeared in 4.1BSD. The autoconfiguration frame- work was completely revised in 4.4BSD. The detach and activate/deacti- vate interfaces appeared in NetBSD 1.5. NetBSD 3.0 October 5, 2002 NetBSD 3.0
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.