- NetBSD Manual Pages
WI(4) NetBSD Programmer's Manual WI(4)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
wi - WaveLAN/IEEE and PRISM-II 802.11 PCMCIA wireless network driver
wi* at pcmcia? function ?
The wi driver provides support for Lucent Technologies WaveLAN/IEEE PC-
CARD adapters (also known as WaveLAN II cards) and various PCCARD
adapters which use Intersil PRISM-II chipsets. Note that while Lucent
sells both ISA and PCMCIA WaveLAN/IEEE devices, the ISA product is actu-
ally a PCMCIA card in an ISA to PCMCIA bridge adapter. Consequently, the
wi driver is required for both the ISA and PCMCIA NICs. Also note that
some of the PRISM-II adapters works only at 3.3V, hence cardbus(4) sup-
port is required for those cards to set VCC correctly, even they are
The core of the WaveLAN/IEEE is the Lucent Hermes controller. All
host/device interaction is via programmed I/O with the Hermes. The Her-
mes supports 802.11 and 802.3 frames, power management, BSS, WDS and ad-
hoc operation modes. The Silver and the Gold cards of the WaveLAN/IEEE
also support WEP. Unlike the other IEEE 802.11 network cards, the Wave-
LAN Gold cards accept 104 bits key (13 characters) for WEP encryption.
The Intersil PRISM-II controller supports WEP as well.
The wi driver encapsulates all IP and ARP traffic as 802.11 frames, how-
ever it can receive either 802.11 or 802.3 frames. Transmit speed is se-
lectable between 1Mbps fixed, 2Mbps fixed or 2Mbps with auto fallback.
For WaveLAN/IEEE Turbo adapters, speeds up to 6Mbps are available. For
WaveLAN/IEEE Turbo 11Mbps adapters and PRISM-II adapters, speeds up to
11Mbps are available.
By default, the wi driver configures the WaveLAN card for special ad-hoc
operation. In this mode, the nwid is ignored and stations can communi-
cate among each other without the aid of an access point. Note that this
mode is out of IEEE 802.11 specification and the driver cannot interoper-
ate with other cards. To join a service set, the driver must be set for
BSS mode using the ifconfig(8) or wiconfig(8) utility.
For more information on configuring this device, see ifconfig(8) and
Cards supported by the wi driver include:
Lucent Wavelan/IEEE 2.0Mb Bronze
Lucent Wavelan/IEEE 2.0Mb Silver
Lucent WaveLAN/IEEE Turbo
Lucent WaveLAN/IEEE Turbo 11Mbps
Melco AIR CONNECT WLI-PCM-L11
DEC/Cabletron RoamAbout 802.11 DS High Rate
Corega Wireless LAN PCC-11
Melco AIR CONNECT WLI-PCM-L11 cards [*] [+]
DEC/Cabletron RoamAbout 802.11 DS High Rate cards [*] [+]
Corega Wireless LAN PCC-11 cards [*] [+]
ELSA AirLancer MC-11
The original PRISM-I chipset is supported by the awi(4) driver.
wi%d: init failed The WaveLAN failed to come ready after an initializa-
tion command was issued.
wi%d: failed to allocate %d bytes on NIC The driver was unable to allo-
cate memory for transmit frames in the NIC's on-board RAM.
wi%d: device timeout The WaveLAN failed to generate an interrupt to ac-
knowledge a transmit command. One reason can be that the board is mis-
configured, see wiconfig(8).
The IBSS mode is not supported. The execution of wiconfig(8) during the
interface is down produces some error messages.
arp(4), ifmedia(4), netintro(4), ifconfig(8), wiconfig(8)
HCF Light programming specification, http://www.wavelan.com.
The wi device driver first appeared in NetBSD 1.5.
The wi driver was written by Bill Paul <firstname.lastname@example.org>.
NetBSD 1.5 November 12, 2000 2