- NetBSD Manual Pages
PRINTCAP(5) NetBSD Programmer's Manual PRINTCAP(5)
Powered by man-cgi (2021-06-01).
Maintained for NetBSD
by Kimmo Suominen.
Based on man-cgi by Panagiotis Christias.
printcap - printer capability data base
The printcap data base is a simplified version of the termcap(5) data
base used to describe line printers. The spooling system accesses the
printcap file every time it is used, allowing dynamic addition and dele-
tion of printers. Each entry in the data base is used to describe one
printer. This data base may not be substituted for, as is possible for
termcap(5), because it may allow accounting to be bypassed.
The default printer is normally lp, though the environment variable
PRINTER may be used to override this. Each spooling utility supports an
option, -P printer, to allow explicit naming of a destination printer.
Refer to the 4.3 BSD Line Printer Spooler Manual for a complete discus-
sion on how to setup the database for a given printer.
Refer to termcap(5) for a description of the file layout.
Name Type Default Description
af str NULL name of accounting file
br num none if lp is a tty, set the baud rate
cf str NULL cifplot data filter
df str NULL tex data filter (DVI format)
fc num 0 if lp is a tty, clear flag bits
ff str `\f' string to send for a form feed
fo bool false print a form feed when device is opened
fs num 0 like `fc' but set bits
gf str NULL graph data filter (plot(3) format
hl bool false print the burst header page last
ic bool false driver supports (non standard) ioctl to
if str NULL name of text filter which does
lf str /dev/console error logging file name
lo str lock name of lock file
lp str /dev/lp device name to open for output to local
printer, or port@host for remote
printer/printer on print server
ms str NULL list of terminal modes to set or clear
mx num 1000 maximum file size (in BUFSIZ blocks),
zero = unlimited
nd str NULL next directory for list of queues
nf str NULL ditroff data filter (device independent
of str NULL name of output filtering program
pc num 200 price per foot or page in hundredths of
pl num 66 page length (in lines)
pw num 132 page width (in characters)
px num 0 page width in pixels (horizontal)
py num 0 page length in pixels (vertical)
rf str NULL filter for printing FORTRAN style text
rg str NULL restricted group. Only members of group
rm str NULL machine name for remote printer
rp str ``lp'' remote printer name argument
rs bool false restrict remote users to those with
rw bool false open the printer device for reading and
sb bool false short banner (one line only)
sc bool false suppress multiple copies
sd str /var/spool/lpd spool directory
sf bool false suppress form feeds
sh bool false suppress printing of burst page header
st str status status file name
tf str NULL troff data filter (cat phototypesetter)
tr str NULL trailer string to print when queue
vf str NULL raster image filter
xc num 0 if lp is a tty, clear local mode bits
xs num 0 like `xc' but set bits
If the local line printer driver supports indentation, the daemon must
understand how to invoke it.
If a printer is specified via lp (either local or remote), the lpd(8)
daemon creates a pipeline of filters to process files for various printer
types. The pipeline is not set up for remote printers specified via rm
unless the local host is the same as the remote printer host given. The
filters selected depend on the flags passed to lpr(1). The pipeline set
p pr | if regular text + pr(1)
none if regular text
c cf cifplot
d df DVI (tex)
g gf plot(3)
n nf ditroff
f rf Fortran
t tf troff
v vf raster image
The if filter is invoked with arguments:
if [-c] -wwidth -llength -iindent -n login -h host acct-file
The -c flag is passed only if the -l flag (pass control characters liter-
ally) is specified to lpr(1). The Width function and length specify the
page width and length (from pw and pl respectively) in characters. The
-n and -h parameters specify the login name and host name of the owner of
the job respectively. The Acct-file function is passed from the af
If no if is specified, of is used instead, with the distinction that of
is opened only once, while if is opened for every individual job. Thus,
if is better suited to performing accounting. The of is only given the
width and length flags.
All other filters are called as:
filter -xwidth -ylength -n login -h host acct-file
where width and length are represented in pixels, specified by the px and
py entries respectively.
All filters take stdin as the file, stdout as the printer, may log either
to stderr or using syslog(3), and must not ignore SIGINT.
Error messages generated by the line printer programs themselves (that
is, the lp* programs) are logged by syslog(3) using the LPR facility.
Messages printed on stderr of one of the filters are sent to the corre-
sponding lf file. The filters may, of course, use syslog(3) themselves.
Error messages sent to the console have a carriage return and a line feed
appended to them, rather than just a line feed.
termcap(5), lpc(8), lpd(8), pac(8), lpr(1), lpq(1), lprm(1)
4.3 BSD Line Printer Spooler Manual.
The printcap file format appeared in 4.2BSD.
NetBSD 1.5 December 11, 1993 3