inet6(4) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
INET6(4)                  NetBSD Programmer's Manual                  INET6(4)


NAME
inet6 - Internet protocol version 6 family
SYNOPSIS
#include <sys/types.h> #include <netinet/in.h>
DESCRIPTION
The inet6 family is an updated version of inet(4) family. While inet(4) implements Internet Protocol version 4, inet6 implements Internet Proto- col version 6. inet6 is a collection of protocols layered atop the Internet Protocol version 6 (IPv6) transport layer, and utilizing the IPv6 address format. The inet6 family provides protocol support for the SOCK_STREAM, SOCK_DGRAM, and SOCK_RAW socket types; the SOCK_RAW interface provides access to the IPv6 protocol.
ADDRESSING
IPv6 addresses are 16 byte quantities, stored in network standard byte- order. The include file <netinet/in.h> defines this address as a dis- criminated union. Sockets bound to the inet6 family utilize the following addressing struc- ture, struct sockaddr_in6 { u_int8_t sin6_len; u_int8_t sin6_family; u_int16_t sin6_port; u_int32_t sin6_flowinfo; struct in6_addr sin6_addr; u_int32_t sin6_scope_id; }; Sockets may be created with the local address ``::'' (which is equal to IPv6 address 0:0:0:0:0:0:0:0) to effect ``wildcard'' matching on incoming messages. The address in a connect(2) or sendto(2) call may be given as ``::'' to mean ``this host''. ``::'' can be obtained by setting sin6_addr field into 0, or by using the address contained in variable in6addr_any. IPv6 specification defines scoped address, like link-local or site-local address. A scoped address is ambiguous to the kernel, if it is specified without scope identifier. To manipulate scoped addresses properly from the userland, programs must use advanced API defined in RFC2292. Compact description on the advanced API is available in ip6(4). If scoped ad- dresses are specified without explicit scope, the kernel may raise error. Note that scoped addresses are not for daily use at this moment, both from specification and implementation point of view. KAME implementation supports extended numeric IPv6 address notation for link-local addresses, like ``fe80::1%de0'' to specify ``fe80::1 on de0 interface''. The notation is supported by getaddrinfo(3) and getnameinfo(3). Some of normal userland programs, such as telnet(1) or ftp(1), are able to use the notation. With special programs like ping6(8), you can specify outgoing interface by extra command line option to disambiguate scoped addresses. Scoped addresses are handled specially in the kernel. In the kernel structures like routing tables or interface structure, scoped addresses will have its interface index embedded into the address. Therefore, the address on some of the kernel structure is not the same as that on the wire. The embedded index will become visible on PF_ROUTE socket, kernel memory accesses via kvm(3) and some other occasions. HOWEVER, users should never use the embedded form. For details please consult sys/netinet6/IMPLEMENTATION.
PROTOCOLS
The inet6 family is comprised of the IPv6 network protocol, Internet Con- trol Message Protocol version 6 (ICMPv6), Transmission Control Protocol (TCP), and User Datagram Protocol (UDP). TCP is used to support the SOCK_STREAM abstraction while UDP is used to support the SOCK_DGRAM ab- straction. Note that TCP and UDP are common to inet(4) and inet6. A raw interface to IPv6 is available by creating an Internet socket of type SOCK_RAW. The ICMPv6 message protocol is accessible from a raw socket. Interaction between IPv4/v6 sockets The behavior of AF_INET6 TCP/UDP socket is documented in RFC2553. Basi- cally, it says as follows: + Specific bind on AF_INET6 socket (bind(2) with address specified) should accept IPv6 traffic to that address only. + If you perform wildcard bind on AF_INET6 socket (bind(2) to IPv6 address ::), and there is no wildcard bind AF_INET socket on that TCP/UDP port, IPv6 traffic as well as IPv4 traffic should be routed to that AF_INET6 socket. IPv4 traffic should be seen as if it came from IPv6 address like ::ffff:10.1.1.1. This is called IPv4 mapped address. + If there are both wildcard bind AF_INET socket and wildcard bind AF_INET6 socket on one TCP/UDP port, they should behave separately. IPv4 traffic should be routed to AF_INET socket and IPv6 should be routed to AF_INET6 socket. However, RFC2553 does not define the constraint between the order of bind(2), nor how IPv4 TCP/UDP port number and IPv6 TCP/UDP port number relate each other (should they be integrated or separated). Implemented behavior is very different across kernel to kernel. Therefore, it is un- wise to rely too much upon the behavior of AF_INET6 wildcard bind socket. It is recommended to listen to two sockets, one for AF_INET and another for AF_INET6, when you would like to accept both IPv4 and IPv6 traffic. It should also be noted that malicious parties can take advantage of the complexity presented above, and are able to bypass access control, if the target node routes IPv4 traffic to AF_INET6 socket. Users are advised to take caution handling connections from IPv4 mapped address to AF_INET6 sockets. Because of the above, by default, NetBSD does not route IPv4 traffic to AF_INET6 socket. Listen to two sockets if you want to accept both IPv4 and IPv6 traffic. IPv4 traffic may be routed with certain per-sock- et/per-node configuration, however, it is not recommended to do so. Con- sult ip6(4) for details.
SEE ALSO
ioctl(2), socket(2), sysctl(3), icmp6(4), intro(4), ip6(4), tcp(4), udp(4)
STANDARDS
Tatsuya Jinmei, and Atsushi Onoe, An Extension of Format for IPv6 Scoped Addresses, internet draft, draft-ietf-ipngwg-scopedaddr-format-01.txt, March 2000, work in progress material.
HISTORY
The inet6 protocol interface are defined in RFC2553 and RFC2292. The implementation described herein appeared in WIDE/KAME project.
BUGS
The IPv6 support is subject to change as the Internet protocols develop. Users should not depend on details of the current implementation, but rather the services exported. Users are suggested to implement ``version independent'' code as much as possible, as you will need to support both inet(4) and inet6. NetBSD 1.5 January 29, 1999 3
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.