usb(4) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
USB(4)                    NetBSD Programmer's Manual                    USB(4)


NAME
usb - Universal Serial Bus driver
SYNOPSIS
uhci* at pci? function ? ohci* at pci? function ? usb* at uhci? usb* at ohci? uhub* at usb? uhub* at uhub? port ? configuration ? interface ? XX* at uhub? port ? configuration ? interface ? #include <dev/usb/usb.h> #include <dev/usb/usbhid.h>
INTRODUCTION
NetBSD provides machine-independent bus support and drivers for USB de- vices. The NetBSD usb driver has three layers (like scsi(4) and pcmcia(4)): the controller, the bus, and the device layer. The controller attaches to a physical bus (like pci(4)). The USB bus attaches to the controller and the root hub attaches to the controller. Further devices, which may in- clude further hubs, attach to other hubs. The attachment forms the same tree structure as the physical USB device tree. For each USB device there may be additional drivers attached to it. The uhub device controls USB hubs and must always be present since there is at least a root hub in any USB system.
INTRODUCTION TO USB
The USB is a 12 Mb/s serial bus (1.5 Mb/s for low speed devices). Each USB has a host controller that is the master of the bus; all other de- vices on the bus only speak when spoken to. There can be up to 127 devices (apart from the host controller) on a bus, each with its own address. The addresses are assigned dynamically by the host when each device is attached to the bus. Within each device there can be up to 16 endpoints. Each endpoint is in- dividually addressed and the addresses are static. Each of these end- points will communicate in one of four different modes: control, isochronous, bulk, or interrupt. A device always has at least one end- point. This endpoint has address 0 and is a control endpoint and is used to give commands to and extract basic data, such as descriptors, from the device. Each endpoint, except the control endpoint, is unidirectional. The endpoints in a device are grouped into interfaces. An interface is a logical unit within a device; e.g. a compound device with both a key- board and a trackball would present one interface for each. An interface can sometimes be set into different modes, called alternate settings, which affects how it operates. Different alternate settings can have different endpoints within it. A device may operate in different configurations. Depending on the con- figuration the device may present different sets of endpoints and inter- faces. Each device located on a hub has several config(8) locators: port this is the number of the port on closest upstream hub. configuration this is the configuration the device must be in for this driver to attach. This locator does not set the configuration; it is iterated by the bus enumeration. interface this is the interface number within a device that an interface driver attaches to. The bus enumeration of the USB bus proceeds in several steps: 1. Any device specific driver can to attach to the device. 2. If none is found, any device class specific driver can attach. 3. If none is found, all configurations are iterated over. For each configuration all the interface are iterated over and interface drivers can attach. If any interface driver attached in a certain configuration the iteration over configurations is stopped. 4. If still no drivers have been found, the generic USB driver can at- tach.
USB CONTROLLER INTERFACE
Use the following to get access to the USB specific structurs and de- fines. #include <sys/dev/usb.h> The /dev/usbN can be opened and a few operations can be performed on it. The poll(2) system call will say that I/O is possible on the controller device when a USB device has been connected or disconnected to the bus. The following ioctl(2) commands are supported on the controller device: USB_DISCOVER This command will cause a complete bus discovery to be initiated. If any devices attached or detached from the bus they will be processed during this command. This is the only way that new de- vices are found on the bus. USB_DEVICEINFO struct usb_device_info This command can be used to retrieve some information about a de- vice on the bus. The addr field should be filled before the call and the other fields will be filled by information about the de- vice on that address. Should no such device exist an error is reported. struct usb_device_info { uByte addr; /* device address */ char product[USB_MAX_STRING_LEN]; char vendor[USB_MAX_STRING_LEN]; char revision[8]; uByte class; uByte config; uByte lowspeed; int power; int nports; uByte ports[16]; #define USB_PORT_ENABLED 0xff #define USB_PORT_SUSPENDED 0xfe #define USB_PORT_POWERED 0xfd #define USB_PORT_DISABLED 0xfc }; The product, vendor, and revision fields contain self-explanatory descriptions of the device. The class field contains the device class. The config field shows the current configuration of the device. The lowspeed field is set if the device is a USB low speed de- vice. The power field shows the power consumption in milli-amps drawn at 5 volts, or zero if the device is self powered. If the device is a hub the nports field is non-zero and the ports field contains the addresses of the connected devices. If no de- vice is connected to a port one of the USB_PORT_* values indi- cates its status. USB_DEVICESTATS struct usb_device_stats This command retrieves statistics about the controller. struct usb_device_stats { u_long requests[4]; }; The requests field is indexed by the transfer kind, i.e. UE_*, and indicates how many transfers of each kind that has been com- pleted by the controller. USB_REQUEST struct usb_ctl_request This command can be used to execute arbitrary requests on the control pipe. This is DANGEROUS and should be used with great care since it can destroy the bus integrity. The include file <dev/usb/usb.h> contains definitions for the types used by the various ioctl(2) calls. The naming convention of the fields for the various USB descriptors exactly follows the naming in the USB speci- fication. Byte sized fields can be accessed directly, but word (16 bit) sized fields must be access by the UGETW(field) and USETW(field, value) macros to handle byte order and alignment properly. The include file <dev/usb/usbhid.h> similarly contains the definitions for Human Interface Devices (HID).
SEE ALSO
The USB specifications can be found at http://www.usb.org/developers/docs.htm. pci(4), uaudio(4), ugen(4), uhid(4), ukbd(4), ulpt(4), ums(4), usbd(8), usbdevs(8)
HISTORY
The usb driver appeared in NetBSD 1.4. NetBSD 1.4 July 12, 1998 3
Powered by man-cgi (2024-03-18). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.