options(4) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
OPTIONS(4)                NetBSD Programmer's Manual                OPTIONS(4)


NAME
options - Miscellaneous kernel configuration options
SYNOPSIS
options ...
DESCRIPTION
This manual page describes a number of miscellaneous kernel configuration options that may be specified in a kernel config file. See config(8) for information on how to configure and build kernels. Note: Options are passed to the compile process as -D flags to the C compiler. Compatibility Options options COMPAT_09 Enable binary compatibility with NetBSD 0.9. This enables support for 16-bit user, group, and process ids (following revisions support 32-bit identifiers), It also allows the use of the deprecated getdomainname(3), setdomainname(3), and uname(3) syscalls. This option also allows using numeric filesystem identifiers rather than strings. Post NetBSD 0.9 ver- sions use string identifiers. options COMPAT_10 Enable binary compatibility with NetBSD 1.0. This option allows the use of the filesystem name of ``ufs'' as an alias for ``ffs''. The name ``ffs'' should be used post 1.0 in /etc/fstab and other files. It also adds old syscalls for the AT&T System V UNIX shared memory interface. This was changed post 1.0 to work on 64-bit architectures. This option also enables ``sgtty'' compatibility, without which programs using the old interface produce an ``inappropriate ioctl'' error, and /dev/io only works when this option is set in the kernel, see io(4) on ports that sup- port it. options COMPAT_11 Enable binary compatibility with NetBSD 1.1. This allows binaries run- ning on the i386 port to gain direct access to the io ports by opening /dev/io read/write. This functionality was replaced by i386_iopl(2) post 1.1. On the Atari port, the location of the disk label was moved after 1.1. When the COMPAT_11 option is set, the kernel will read (pre) 1.1 style disk labels as a last resort. When a disklabel is re-written, the old style label will be replaced with a post 1.1 style label. This also enables EXEC_ELF_NOTELESS option. options COMPAT_12 Enable binary compatibility with NetBSD 1.2. This allows the use of old syscalls for reboot() and swapon(). The syscall numbers were changed post 1.2 to add functionality to the reboot(2) syscall, and the new swapctl(2) interface was introduced. This also enables EXEC_ELF_NOTELESS option. options COMPAT_13 Enable binary compatibility with NetBSD 1.3. This allows the use of old syscalls for sigaltstack(), and also enables the old swapctl(2) command SWAP_STATS (now called SWAP_OSTATS), which does not include the se_path member of struct swapent. options COMPAT_14 Enable binary compatibility with NetBSD 1.4. This allows some old ioctl(2) on wscons(4) to be performed, and allows the NFSSVC_BIOD mode of the nfssvc(2) system call to be used for compatibility with the deprecat- ed nfsiod program. options COMPAT_43 Enables compatibility with 4.3BSD. This adds an old syscall for lseek(2). It also adds the ioctls for TIOCGETP and TIOCSETP. The return values for getpid(2), getgid(2), and getuid(2) syscalls are modified as well, to return the parent's pid and uid as well as the current pro- cess's. It also enables the deprecated NTTYDISC terminal line disci- pline. It also provides backwards compatibility with ``old'' SIOC[GS]IF{ADDR,DSTADDR,BRDADDR,NETMASK} interface ioctls, including bi- nary compatibility with code written before the introduction of the sa_len field in sockaddrs. It also enables support for some older pre 4.4BSD socket calls. options COMPAT_SVR4 On those architectures that support it, this enables binary compatibility with AT&T System V.4 UNIX applications built for the same architecture. This currently includes the i386, m68k and sparc port. options COMPAT_LINUX On those architectures that support it, this enables binary compatibility with Linux ELF and a.out(5) applications built for the same architecture. This currently includes the alpha, i386, powerpc, and m68k ports. There is also a minimal support for running Linux binaries on Mips ports, but it is experimental at the moment. options COMPAT_SUNOS On those architectures that support it, this enables binary compatibility with SunOS 4.1 applications built for the same architecture. This cur- rently includes the sparc, sparc64 and most or all m68k ports. Note that the sparc64 requires the COMPAT_NETBSD32 option for 64-bit kernels, in addition to this option. options COMPAT_ULTRIX On those architectures that support it, this enables binary compatibility with Ultrix applications built for the same architecture. This currently is limited to the pmax. The functionality of this option is unknown. options COMPAT_FREEBSD On those architectures that support it, this enables binary compatibility with FreeBSD applications built for the same architecture. At the moment this is limited to the i386 port. options COMPAT_HPUX On those architectures that support it, this enables binary compatibility with HP/UX applications built for the same architecture. This is limited to the hp300 port, and has some known bugs. A limited set of programs do work. options COMPAT_IBCS2 On those architectures that support it, this enables binary compatibility with iBCS2 or SVR3 applications built for the same architecture. This is currently limited to the i386 and vax ports. options COMPAT_IRIX On those architectures that support it, this enables binary compatibility with IRIX o32 binaries built for the same architecture. This feature is experimental, and it is currently limited to the sgimips port of NetBSD. options COMPAT_OSF1 On those architectures that support it, this enables binary compatibility with Digital UNIX (formerly OSF/1) applications built for the same archi- tecture. This is currently limited to the alpha port. options COMPAT_NOMID Enable compatibility with a.out(5) executables that lack a machine ID. This includes NetBSD 0.8's ZMAGIC format, and 386BSD and BSDI's QMAGIC, NMAGIC, and OMAGIC a.out(5) formats. options COMPAT_NETBSD32 On those architectures that support it, this enables binary compatibility with 32-bit applications built for the same architecture. This is cur- rently limited to the sparc64 port, and only applicable for 64-bit ker- nels. options COMPAT_SVR4_32 On those architectures that support it, this enables binary compatibility with 32-bit SVR4 applications built for the same architecture. This is currently limited to the sparc64 port, and only applicable for 64-bit kernels. options COMPAT_AOUT_M68K On m68k architectures which have switched to ELF, this enable binary com- patibility with NetBSD/m68k a.out(5) executables on NetBSD/m68k ELF ker- nel. This handles alignment incompatibility of m68k ABI between a.out and ELF which causes the structure padding differences. Currently only some system calls which use struct stat are adjusted and some binaries which use sysctl(3) to retrieve network details would not work properly. options EXEC_ELF_NOTELESS Run unidentified ELF binaries as NetBSD binaries. This might be needed for very old NetBSD ELF binaries on some archs. These old binaries didn't contain an appropriate .note.netbsd.ident section, and thus can't be identified by the kernel as NetBSD binaries otherwise. Beware - if this option is on, the kernel would run any unknown ELF binaries as if they were NetBSD binaries. Debugging Options options DDB Compiles in a kernel debugger for diagnosing kernel problems. See ddb(4) for details. NOTE: not available on all architectures. options DDB_FROMCONSOLE=integer If set to non-zero, DDB may be entered by sending a break on a serial console or by a special key sequence on a graphics console. A value of "0" ignores console breaks or key sequences, It not explicitly specified, the default value is "1". Note that this sets the value of the ddb.fromconsole sysctl(3) variable which may be changed at run time -- see sysctl(8) for details. options DDB_HISTORY_SIZE=integer If this is non-zero, enable history editing in the kernel debugger and set the size of the history to this value. options DDB_ONPANIC If set to non-zero, DDB will be entered upon kernel panic. The default if not specified is "1". Note that this sets the value of the ddb.onpanic sysctl(3) variable which may be changed at run time -- see sysctl(8) for details. options DDB_BREAK_CHAR=integer This option overrides the using break to enter the kernel debugger on the serial console. The value given will is the ascii value to be used in- stead. This is currently only supported by the com driver. options KGDB Compiles in a remote kernel debugger stub for diagnosing kernel problems using the ``remote target'' feature of gdb. See gdb(1) for details. NOTE: not available on all architectures. options KGDB_DEV Device number (as a dev_t) of kgdb device. options KGDB_DEVADDR Memory address of kgdb device. options KGDB_DEVMODE Permissions of kgdb device. options KGDB_DEVNAME Device name of kgdb device. options KGDB_DEVRATE Baud rate of kgdb device. makeoptions DEBUG="-g" The -g flag causes netbsd.gdb to be built in addition to netbsd. netbsd.gdb is useful for debugging kernel crash dumps with gdb. The com- mand gdb -k invokes gdb in kernel debugger mode. See gdb(1) for details. This also turns on options DEBUG (which see). options DEBUG Turns on miscellaneous kernel debugging. Since options are turned into preprocessor defines (see above), options DEBUG is equivalent to doing a #define DEBUG throughout the kernel. Much of the kernel has #ifdef DEBUG conditionalized debugging code. Note that many parts of the kernel (typ- ically device drivers) include their own #ifdef XXX_DEBUG conditionals instead. This option also turns on certain other options, which may de- crease system performance. options DIAGNOSTIC Adds code to the kernel that does internal consistency checks. This code will cause the kernel to panic if corruption of internal data structures is detected. These checks can decrease performance up to 15%. options KTRACE Add hooks for the system call tracing facility, which allows users to watch the system call invocation behavior of processes. See ktrace(1) for details. options MSGBUFSIZE=integer This option sets the size of the kernel message buffer. This buffer holds the kernel output of printf() when not (yet) read by syslogd(8). This is particularly useful when the system has crashed and you wish to lookup the kernel output from just before the crash. Also, since the au- toconfig output becomes more and more verbose, it sometimes happens that the message buffer overflows before syslogd(8) was able to read it. Note that not all systems are capable of obtaining a variable sized message buffer. There are also some systems on which memory contents are not preserved across reboots. options MALLOCLOG Enables an event log for malloc(9). Useful for tracking down ``Data modified on freelist'' and ``multiple free'' problems. options MALLOCLOGSIZE=integer Defines the number of entries in the malloc log. Default is 100000 en- tries. options UVMHIST Enables the UVM history logs, which create in-memory traces of various UVM activities. These logs can be displayed be calling uvmhist_dump() or uvm_hist() with appropriate arguments from DDB. See the kernel source file sys/uvm/uvm_stat.c for details. options UVMHIST_PRINT Prints the UVM history logs on the system console as entries are added. Note that the output is extremely voluminous, so this option is really only useful for debugging the very earliest parts of kernel initializa- tion. File Systems file-system FFS Includes code implementing the Berkeley Fast File System (FFS). Most ma- chines need this if they are not running diskless. file-system EXT2FS Includes code implementing the Second Extended File System (EXT2FS) , re- vision 0 and revision 1 with the filetype and sparse_super options. This is the most commonly used file system on the Linux operating system, and is provided here for compatibility. Some of the specific features of EXT2FS like the "behavior on errors" are not implemented. This file sys- tem can't be used with UID or GID greater than 65535. See mount_ext2fs(8) for details. file-system LFS [EXPERIMENTAL] Include the Log-structured File System (LFS). See mount_lfs(8) and newfs_lfs(8) for details. file-system MFS Include the Memory File System (MFS). This file system stores files in swappable memory, and produces notable performance improvements when it is used as the file store for /tmp and similar file systems. See mount_mfs(8) for details. file-system NFS Include the client side of the Network File System (NFS) remote file sharing protocol. Although the bulk of the code implementing NFS is ker- nel based, several user level daemons are needed for it to work. See mount_nfs(8) for details. file-system CD9660 Includes code for the ISO 9660 + Rock Ridge file system, which is the standard file system on many CD-ROM discs. Useful primarily if you have a CD-ROM drive. See mount_cd9660(8) for details. file-system MSDOSFS Includes the MS-DOS FAT file system, which is reportedly still used by unfortunate people who have not heard about NetBSD. Also implements the Windows 95 extensions to the same, which permit the use of longer, mixed case file names. See mount_msdos(8) and fsck_msdos(8) for details. file-system NTFS [EXPERIMENTAL] Includes code for the Microsoft Windows NT file system. See mount_ntfs(8) for details. file-system FDESC Includes code for a file system, conventionally mounted on /dev/fd, which permits access to the per-process file descriptor space via special files in the file system. See mount_fdesc(8) for details. Note that this fa- cility is redundant, and thus unneeded on most NetBSD systems, since the fd(4) pseudodevice driver already provides identical functionality. On most NetBSD systems, instances of fd(4) are mknoded under /dev/fd/ and on /dev/stdin, /dev/stdout, and /dev/stderr. file-system KERNFS Includes code which permits the mounting of a special file system (nor- mally mounted on /kern) in which files representing various kernel vari- ables and parameters may be found. See mount_kernfs(8) for details. file-system NULLFS Includes code for a loopback file system. This permits portions of the file hierarchy to be re-mounted in other places. The code really exists to provide an example of a stackable file system layer. See mount_null(8) for details. file-system OVERLAY Includes code for a file system filter. This permits the overlay file system to intercept all access to an underlying file system. This file system is intended to serve as an example of a stacking file system which has a need to interpose itself between an underlying file system and all other access. See mount_overlay(8) for details. file-system PORTAL [EXPERIMENTAL] Includes the portal filesystem. This permits interesting tricks like opening TCP sockets by opening files in the file system. The portal file system is conventionally mounted on /p and is partially im- plemented by a special daemon. See mount_portal(8) for details. file-system PROCFS Includes code for a special file system (conventionally mounted on /proc) in which the process space becomes visible in the file system. Among other things, the memory spaces of processes running on the system are visible as files, and signals may be sent to processes by writing to ctl files in the procfs namespace. See mount_procfs(8) for details. file-system UMAPFS Includes a loopback file system in which user and group ids may be remapped -- this can be useful when mounting alien file systems with dif- ferent uids and gids than the local system. See mount_umap(8) for de- tails. file-system UNION [EXPERIMENTAL] Includes code for the union file system, which permits di- rectories to be mounted on top of each other in such a way that both file systems remain visible -- this permits tricks like allowing writing (and the deleting of files) on a read-only file system like a CD-ROM by mount- ing a local writable file system on top of the read-only file system. See mount_union(8) for details. file-system CODA [EXPERIMENTAL] Includes code for the Coda file system. Coda is a dis- tributed file system like NFS and AFS. It is freely available, like NFS, but it functions much like AFS in being a ``stateful'' file system. Both Coda and AFS cache files on your local machine to improve performance. Then Coda goes a step further than AFS by letting you access the cached files when there is no available network, viz. disconnected laptops and network outages. In Coda, both the client and server are outside the kernel which makes them easier to experiment with. Coda is available for several UNIX and non-UNIX platforms. See http://www.coda.cs.cmu.edu for more details. NOTE: You also need to enable the pseudo-device, vcoda, for the Coda filesystem to work. File System Options options NFSSERVER Include the server side of the NFS (Network File System) remote file sharing protocol. Although the bulk of the code implementing NFS is ker- nel based, several user level daemons are needed for it to work. See mountd(8) and nfsd(8) for details. options QUOTA Enables kernel support for file system quotas. See quotaon(8), edquota(8), and quota(1) for details. Note that quotas only work on ``ffs'' file systems, although rpc.rquotad(8) permits them to be accessed over NFS. options FFS_EI Enable ``Endian-Independent'' FFS support. This allows a system to mount an FFS filesystem created for another architecture, at a small perfor- mance cost for all FFS filesystems. See also newfs(8), fsck_ffs(8), dumpfs(8) for filesystem byte order status and manipulation. options NVNODE=integer This option sets the size of the cache used by the name-to-inode transla- tion routines, (a.k.a. the namei() cache, though called by many other names in the kernel source). By default, this cache has NPROC (set as 20 + 16 * MAXUSERS) * (80 + NPROC / 8) entries. A reasonable way to derive a value of NVNODE, should you notice a large number of namei cache misses with a tool such as systat(1), is to examine your system's current com- puted value with sysctl(8), (which calls this parameter "kern.maxvnodes") and to increase this value until either the namei cache hit rate improves or it is determined that your system does not benefit substantially from an increase in the size of the namei cache. options NAMECACHE_ENTER_REVERSE Causes the namei cache to always enter a reverse mapping (vnode -> name) as well as a normal one. Normally, this is already done for directory vn- odes, to speed up the getcwd operation. This option will cause longer hash chains in the reverse cache, and thus slow down getcwd somewhat. However, it does make vnode -> path translations possible in some cases. For now, only useful if strict /proc/#/maps emulation for Linux binaries is required. options EXT2FS_SYSTEM_FLAGS This option changes the behavior of the APPEND and IMMUTABLE flags for a file on an EXT2FS filesystem. Without this option, the superuser or own- er of the file can set and clear them. With this option, only the supe- ruser can set them, and they can't be cleared if the securelevel is greater than 0. See also chflags(1). options NFS_BOOT_BOOTP Enable use of the BOOTP protocol (RFC 951, 1048) to get configuration in- formation if NFS is used to mount the root file system. See diskless(8) for details. options NFS_BOOT_DHCP Same as ``NFS_BOOT_BOOTP'', but use the DHCP extensions to the BOOTP pro- tocol (RFC 1541). options NFS_BOOT_BOOTP_REQFILE Specifies the string sent in the bp_file field of the BOOTP / DHCP re- quest packet. options NFS_BOOT_BOOTPARAM Enable use of the BOOTPARAM protocol, consisting of RARP and BOOTPARAM RPC, to get configuration information if NFS is used to mount the root file system. See diskless(8) for details. options NFS_BOOT_RWSIZE=value Set the initial NFS read and write sizes for diskless-boot requests. The normal default is 8Kbytes. This option provides a way to lower the value (e.g., to 1024 bytes) as a workaround for buggy network interface cards or boot proms. Once booted, the read and write request sizes can be in- creased by remounting the filesystem. See mount_nfs(8) for details. options NFS_V2_ONLY Reduce the size of the NFS client code by omitting code that's only re- quired for NFSv3 and NQNFS support, leaving only that code required to use NFSv2 servers. Miscellaneous Options options LKM Enable loadable kernel modules. See lkm(4) for details. NOTE: not available on all architectures. options INSECURE Hardwires the kernel security level at -1. This means that the system always runs in secure level 0 mode, even when running multiuser. See the manual page for init(8) for details on the implications of this. The kernel secure level may manipulated by the superuser by altering the kern.securelevel sysctl(3) variable (the secure level may only be lowered by a call from process ID 1, i.e. init(8)). See also sysctl(8) and sysctl(3). options UCONSOLE Normally, only the superuser can execute the TIOCCONS ioctl(2), which redirects console output to a non-console tty. See tty(4) for details. This option permits any user to execute the TIOCCONS ioctl(2). This is useful on machines such as personal workstations which run X(7) servers, where one would prefer to permit console output to be viewed in a window without requiring a suid root program to do it. options MEMORY_DISK_HOOKS This option allows for some machine dependent functions to be called when the md(4) RAM disk driver is configured. This can result in automatical- ly loading a RAM disk from floppy on open (among other things). options MEMORY_DISK_IS_ROOT Forces the md(4) RAM disk to be the root device. This can only be over- ridden when the kernel is booted in the 'ask-for-root' mode. options MEMORY_DISK_ROOT_SIZE=integer Allocates the given number of 512 byte blocks as memory for the md(4) RAM disk, to be populated with mdsetimage(8). options VNODE_OP_NOINLINE Do not inline the VOP_*() calls in the kernel. On i386 GENERIC, this saves 36k of kernel text. Useful for install media kernels, small memory systems and embedded systems. options MALLOC_NOINLINE Time critical fixed size memory allocation is performed with MALLOC() and FREE(). Normally these expand to inline code, but with MALLOC_NOINLINE these call the normal malloc() and free() functions. Useful for install media kernels, small memory systems and embedded systems. options HZ=integer On ports that support it, set the system clock frequency (see hz(9)) to the supplied value. Handle with care. options NTP Turns on in-kernel precision timekeeping support used by software imple- menting NTP (Network Time Protocol, RFC1305). The NTP option adds an in- kernel Phase-Locked Loop (PLL) for normal NTP operation, and a Frequency- Locked Loop (FLL) for intermittently-connected operation. ntpd(8) will employ a user-level PLL when kernel support is unavailable, but the in- kernel version has lower latency and more precision, and so typically keeps much better time. The interface to the kernel NTP support is pro- vided by the ntp_adjtime(2) and ntp_gettime(2) system calls, which are intended for use by ntpd(8) and are enabled by the option. On systems with sub-microsecond resolution timers, or where (HZ / 100000) is not an integer, the NTP option also enables extended-precision arithmetic to keep track of fractional clock ticks at NTP time-format precision. options PPS_SYNC This option enables a kernel serial line discipline for receiving time phase signals from an external reference clock such as a radio clock. (The NTP option (which see) must be on if the PPS_SYNC option is used.) Some reference clocks generate a Pulse Per Second (PPS) signal in phase with their time source. The PPS line discipline receives this signal on either the data leads or the DCD control lead of a serial port. NTP uses the PPS signal to discipline the local clock oscillator to a high degree of precision (typically less than 50 microseconds in time and 0.1 ppm in accuracy). PPS can also generate a serial output pulse when the system receives a PPS interrupt. This can be used to measure the system inter- rupt latency and thus calibrate NTP to account for it. Using PPS usually requires a gadget box to convert from TTL to RS-232 signal levels. The gadget box and PPS are described in more detail in the HTML documentation for ntpd(8) in /usr/share/doc/html/ntp. options SETUIDSCRIPTS Allows scripts with the setuid bit set to execute as the effective user rather than the real user, just like binary executables. NOTE: Using this option will also enable options FDSCRIPTS option FDSCRIPTS Allows execution of scripts with the execute bit set, but not the read bit, by opening the file and passing the file descriptor to the shell, rather than the filename. NOTE: Execute only (non-readable) scripts will have argv[0] set to /dev/fd/*. What this option allows as far as security is concerned, is the ability to safely ensure that the correct script is run by the inter- preter, as it is passed as an already open file. options PUCCN Enables treating serial ports found on PCI boards puc(4) as potential console devices. The method for choosing such a console device is port dependent. options RTC_OFFSET=integer The kernel (and typically the hardware battery backed-up clock on those machines that have one) keeps time in UTC (Universal Coordinated Time, once known as GMT, or Greenwich Mean Time) and not in the time of the lo- cal time zone. The RTC_OFFSET option is used on some ports (such as the i386) to tell the kernel that the hardware clock is offset from UTC by the specified number of minutes. This is typically used when a machine boots several operating systems and one of them wants the hardware clock to run in the local time zone and not in UTC, e.g. RTC_OFFSET=300 means the hardware clock is set to US Eastern Time (300 minutes behind UTC), and not UTC. (Note: RTC_OFFSET is used to initialize a kernel variable named rtc_offset which is the source actually used to determine the clock offset, and which may be accessed via the kern.rtc_offset sysctl vari- able. See sysctl(8) and sysctl(3) for details. Since the kernel clock is initialized from the hardware clock very early in the boot process, it is not possible to meaningfully change rtc_offset in system initializa- tion scripts. Changing this value currently may only be done at kernel compile time or by patching the kernel and rebooting). NOTE: Unfortunately, in many cases where the hardware clock is kept in local time, it is adjusted for Daylight Savings Time; this means that at- tempting to use RTC_OFFSET to let NetBSD coexist with such an operating system, like Windows, would necessitate changing RTC_OFFSET twice a year. As such, this solution is imperfect. options KMEMSTATS The kernel memory allocator, malloc(9), will keep statistics on its per- formance if this option is enabled. Unfortunately, this option therefore essentially disables the MALLOC() and FREE() forms of the memory alloca- tor, which are used to enhance the performance of certain critical sec- tions of code in the kernel. This option therefore can lead to a signif- icant decrease in the performance of certain code in the kernel if en- abled. Examples of such code include the namei() routine, the ccd(4) driver, the ncr(4) driver, and much of the networking code. options MAXUPRC=integer Sets the soft RLIMIT_NPROC resource limit, which specifies the maximum number of simultaneous processes a user is permitted to run, for process 0; this value is inherited by its child processes. It defaults to CHILD_MAX, which is currently defined to be 160. Setting MAXUPRC to a value less than CHILD_MAX is not permitted, as this would result in a vi- olation of the semantics of IEEE Std 1003.1-1990 (``POSIX''). options DEFCORENAME=string Sets the default value of the kern.defcorename sysctl variable, otherwise it is set to %n.core. See sysctl(8) and sysctl(3) for details. options RASOPS_CLIPPING Enables clipping within the rasops raster-console output system. NOTE: only available on architectures that use rasops for console output. options RASOPS_SMALL Removes optimized character writing code from the rasops raster-console output system. NOTE: only available on architectures that use rasops for console output. options INCLUDE_CONFIG_FILE Embeds the kernel config file used to define the kernel in the kernel bi- nary itself. The embedded data also includes any files directly included by the config file itself, e.g. GENERIC.local or std.$MACHINE. The em- bedded config file can be extracted from the resulting kernel by the fol- lowing command: strings netbsd | sed -n 's/^_CFG_//p' | unvis options INCLUDE_JUST_CONFIG Similar to the above option, but includes just the actual config file, not any included files. options PIPE_SOCKETPAIR Use slower, but smaller socketpair(2)-based pipe implementation instead of default faster, but bigger one. Primarily useful for installation ker- nels. options USERCONF Compiles in the in-kernel device configuration manager. See userconf(4) for details. options PERFCTRS Compiles in kernel support for CPU performance-monitoring counters. See pmc(1) for details. NOTE: not available on all architectures. Networking Options options GATEWAY Enables IPFORWARDING (which see) and (on most ports) increases the size of NMBCLUSTERS (which see). In general, GATEWAY is used to indicate that a system should act as a router, and IPFORWARDING is not invoked direct- ly. (Note that GATEWAY has no impact on protocols other than IP, such as CLNP or XNS). options IPFORWARDING=value If value is 1 this enables IP routing behavior. If value is 0 (the de- fault), it disables it. The GATEWAY option sets this to 1 automatically. With this option enabled, the machine will forward IP datagrams destined for other machines between its interfaces. Note that even without this option, the kernel will still forward some packets (such as source routed packets) -- removing GATEWAY and IPFORWARDING is insufficient to stop all routing through a bastion host on a firewall -- source routing is con- trolled independently. To turn off source routing, use options IPFORWSRCRT=0 (which see). Note that IP forwarding may be turned on and off independently of the setting of the IPFORWARDING option through the use of the net.inet.ip.forwarding sysctl variable. If net.inet.ip.forwarding is 1, IP forwarding is on. See sysctl(8) and sysctl(3) for details. options IPFORWSRCRT=value If value is set to zero, source routing of IP datagrams is turned off. If value is set to one (the default) or the option is absent, source routed IP datagrams are forwarded by the machine. Note that source rout- ing of IP packets may be turned on and off independently of the setting of the IPFORWSRCRT option through the use of the net.inet.ip.forwsrcrt sysctl variable. If net.inet.ip.forwsrcrt is 1, forwarding of source routed IP datagrams is on. See sysctl(8) and sysctl(3) for details. options IFA_STATS Tells the kernel to maintain per-address statistics on bytes sent and re- ceived over (currently) internet and appletalk addresses. The option is not recommended as it degrades system stability. options MROUTING Includes support for IP multicast routers. You certainly want INET with this. Multicast routing is controlled by the mrouted(8) daemon. options INET Includes support for the TCP/IP protocol stack. You almost certainly want this. See inet(4) for details. This option is currently required. options INET6 Includes support for the IPv6 protocol stack. See inet6(4) for details. Unlike INET, INET6 enables multicast routing code as well. This option requires INET at this moment, but it should not. options ND6_DEBUG The option sets the default value of net.inet6.icmp6.nd6_debug to 1, for debugging IPv6 neighbor discovery protocol handling. See sysctl(3) for details. options IPSEC Includes support for the IPsec protocol. See ipsec(4) for details. IPSEC will enable secret key management part, policy management part, AH and IPComp. Kernel binary will not be subject to export control in most of countries, even if compiled with IPSEC. For example, it should be okay to export it from within the United States to the outside. INET6 and IPSEC are orthogonal so you can get IPv4-only kernel with IPsec sup- port, IPv4/v6 dual support kernel without IPsec, and so forth. This op- tion requires INET at this moment, but it should not. options IPSEC_DEBUG Enables debugging code in IPsec stack. This option assumes IPSEC. options IPSEC_ESP Includes support for IPsec ESP protocol. See ipsec(4) for details. IPSEC_ESP will enable source code that is subject to export control in some countries (including the United States), and compiled kernel binary will be subject to certain restriction. This option assumes IPSEC. options SUBNETSARELOCAL Sets default value for net.inet.ip.subnetsarelocal variable, which con- trols whether non-directly-connected subnets of connected networks are considered "local" for purposes of choosing the MSS for a TCP connection. This is mostly present for historic reasons and completely irrelevant if you enable Path MTU discovery. options HOSTZEROBROADCAST Sets default value for net.inet.ip.hostzerobroadcast variable, which con- trols whether the zeroth host address of each connected subnet is also considered a broadcast address. Default value is "1", for compatibility with old systems; if this is set to zero on all hosts on a subnet, you should be able to fit an extra host per subnet on the ".0" address. options MCLSHIFT=value This option is the base-2 logarithm of the size of mbuf clusters. The BSD networking stack keeps network packets in a linked list, or chain, of kernel buffer objects called mbufs. The system provides larger mbuf clusters as an optimization for large packets, instead of using long chains for large packets. The mbuf cluster size, or MCLBYTES, must be a power of two, and is computed as two raised to the power MCLSHIFT. On systems with Ethernet network adaptors, MCLSHIFT is often set to 11, giv- ing 2048-byte mbuf clusters, large enough to hold a 1500-byte Ethernet frame in a single cluster. Systems with network interfaces supporting larger frame sizes like ATM, FDDI, or HIPPI may perform better with MCLSHIFT set to 12 or 13, giving mbuf cluster sizes of 4096 and 8192 bytes, respectively. options NS Include support for the Xerox XNS protocol stack. See ns(4) for details. options ISO,TPIP Include support for the ubiquitous OSI protocol stack. See iso(4) for details. This option assumes INET. options EON Include support for tunneling OSI protocols over IP. Known to be broken, or at least very fragile, and undocumented. options CCITT,LLC,HDLC Include support for the CCITT (nee ITU-TSS) X.25 protocol stack. The state of this code is currently unknown, and probably contains bugs. This option assumes INET. options NETATALK Include support for the AppleTalk protocol stack. The kernel provides provision for the Datagram Delivery Protocol (DDP), providing SOCK_DGRAM support and AppleTalk routing. This stack is used by the NETATALK pack- age, which adds support for AppleTalk server services via user libraries and applications. options IPNOPRIVPORTS Normally, only root can bind a socket descriptor to a so-called ``privileged'' TCP port, that is, a port number in the range 0-1023. This option eliminates those checks from the kernel. This can be useful if there is a desire to allow daemons without privileges to bind those ports, e.g. on firewalls. The security tradeoffs in doing this are sub- tle. This option should only be used by experts. options TCP_COMPAT_42 TCP bug compatibility with 4.2BSD. In 4.2BSD, TCP sequence numbers were 32-bit signed values. Modern implementations of TCP use unsigned values. This option clamps the initial sequence number to start in the range 2^31 rather than the full unsigned range of 2^32. Also, under 4.2BSD, keepalive packets must contain at least one byte or else the remote end would not respond. options TCP_DEBUG Record the last TCP_NDEBUG TCP packets with SO_DEBUG set, and decode to the console if tcpconsdebug is set. options TCP_NDEBUG Number of packets to record for TCP_DEBUG. Defaults to 100. options PFIL_HOOKS This option turns on the packet filter interface hooks. See pfil(9) for details. This option assumes INET. options IPFILTER_LOG This option, in conjunction with pseudo-device ipfilter, enables logging of IP packets using ip-filter. options IPFILTER_DEFAULT_BLOCK This option sets the default policy of ip-filter. If it is set, ip-fil- ter will block packets by default. options PPP_BSDCOMP Enable support for BSD-compress (`bsdcomp') compression in ppp. options PPP_DEFLATE Enable support for deflate compression in ppp. options PPP_FILTER This option turns on pcap(3) based filtering for ppp connections. This option is used by pppd(8) which needs to be compiled with PPP_FILTER de- fined (the current default). System V IPC Options options SYSVMSG Includes support for AT&T System V UNIX style message queues. See msgctl(2), msgget(2), msgrcv(2), msgsnd(2). options SYSVSEM Includes support for AT&T System V UNIX style semaphores. See semctl(2), semget(2), semop(2). options SEMMNI=value Sets the number of AT&T System V UNIX style semaphore identifiers. The GENERIC config file for your port will have the default. options SEMMNS=value Sets the number of AT&T System V UNIX style semaphores in the system. The GENERIC config file for your port will have the default. options SEMUME=value Sets the maximum number of undo entries per process for AT&T System V UNIX style semaphores. The GENERIC config file for your port will have the default. options SEMMNU=value Sets the number of undo structures in the system for AT&T System V UNIX style semaphores. The GENERIC config file for your port will have the default. options SYSVSHM Includes support for AT&T System V UNIX style shared memory. See shmat(2), shmctl(2), shmdt(2), shmget(2). options SHMMAXPGS=value Sets the maximum number of AT&T System V UNIX style shared memory pages that are available through the shmget(2) system call. Default value is 1024 on most ports. See /usr/include/machine/vmparam.h for the default. VM Related Options options NMBCLUSTERS=value The number of mbuf clusters the kernel supports. Mbuf clusters are MCLBYTES in size (usually 2k). This is used to compute the size of the kernel VM map mb_map, which maps mbuf clusters. Default on most ports is 256 (512 with ``options GATEWAY'' ). See /usr/include/machine/param.h for exact default information. Increase this value if you get ``mb_map full'' messages. options NKMEMPAGES=value options NKMEMPAGES_MIN=value options NKMEMPAGES_MAX=value Size of kernel VM map kmem_map, in PAGE_SIZE-sized chunks (the VM page size; this value may be read from the sysctl(8) variable hw.pagesize ). This VM map is used to map the kernel malloc arena. The kernel attempts to auto-size this map based on the amount of physical memory in the sys- tem. Platform-specific code may place bounds on this computed size, which may be viewed with the sysctl(8) variable vm.nkmempages. See /usr/include/machine/param.h for the default upper and lower bounds. The related options `NKMEMPAGES_MIN' and `NKMEMPAGES_MAX' allow the bounds to be overridden in the kernel configuration file. These options are pro- vided in the event the computed value is insufficient resulting in an ``out of space in kmem_map'' panic. options BUFCACHE=value Size of the buffer cache as a percentage of total available RAM. Ignored if BUFPAGES is also specified. options NBUF=value options BUFPAGES=value These options set the number of pages available for the buffer cache. Their default value is a machine dependent value, often calculated as be- tween 5% and 10% of total available RAM. options MAXTSIZ=bytes Sets the maximum size limit of a process' text segment. See /usr/include/machine/vmparam.h for the port-specific default. options DFLDSIZ=bytes Sets the default size limit of a process' data segment, the value that will be returned as the soft limit for RLIMIT_DATA (as returned by getrlimit(2)). See /usr/include/machine/vmparam.h for the port-specific default. options MAXDSIZ=bytes Sets the maximum size limit of a process' data segment, the value that will be returned as the hard limit for RLIMIT_DATA (as returned by getrlimit(2)). See /usr/include/machine/vmparam.h for the port-specific default. options DFLSSIZ=bytes Sets the default size limit of a process' stack segment, the value that will be returned as the soft limit for RLIMIT_STACK (as returned by getrlimit(2)). See /usr/include/machine/vmparam.h for the port-specific default. options MAXSSIZ=bytes Sets the maximum size limit of a process' stack segment, the value that will be returned as the hard limit for RLIMIT_STACK (as returned by getrlimit(2)). See /usr/include/machine/vmparam.h for the port-specific default. amiga-specific Options options BB060STUPIDROM When the bootloader (which passes AmigaOS ROM information) claims we have a 68060 CPU without FPU, go look into the Processor Configuration Regis- ter (PCR) to find out. You need this with Amiga ROMs up to (at least) V40.xxx (OS3.1), when you boot via the bootblocks and don't have a DraCo. options IOBZCLOCK=frequency The IOBlix boards come with two different serial master clocks: older ones use 24 MHz, newer ones use 22.1184 MHz. The driver normally assumes the latter. If your board uses 24 MHz, you can recompile your kernel with options IOBZCLOCK=24000000 or patch the kernel variable iobzclock to the same value. options LIMITMEM=value If there, limit the part of the first memory bank used by NetBSD to value megabytes. Default is unlimited. options NKPTADD=addvalue options NKPTADDSHIFT=shiftvalue The CPU specific MMU table for the kernel is pre-allocated at kernel startup time. Part of it is scaled with maxproc, to have enough room to hold the user program MMU tables; the second part is a fixed amount for the kernel itself. The third part accounts for the size of the file buffer cache. Its size is either NKPTADD pages (if defined) or memory size in bytes divided by two to the power of NKPTADDSHIFT. The default is undefined NKPTADD and NKPTADDSHIFT=24, allowing for 16 buffers per megabyte of main memory (while a GENERIC kernel allocates about half of that). When you get "can't get KPT page" panics, you should increase NKPTADD (if defined), or decrease NKPTADDSHIFT by one. options P5PPC68KBOARD Add special support for Phase5 mixed 68k+PPC boards. Currently, this only affects rebooting from NetBSD and is only needed on 68040+PPC, not on 68060+PPC; without this, affected machines will hang after NetBSD has shut down and will only restart after a keyboard reset or a power cycle. arm32-specific Options options FRENCH_KEYBOARD Include translation for French keyboards when using pccons(4) on a Shark. options FINNISH_KEYBOARD Include translation for Finnish keyboards when using pccons(4) on a Shark. options GERMAN_KEYBOARD Include translation for German keyboards when using pccons(4) on a Shark. options NORWEGIAN_KEYBOARD Include translation for French keyboards when using pccons(4) on a Shark. atari-specific Options options DISKLABEL_AHDI Include support for AHDI (native Atari) disklabels. options DISKLABEL_NBDA Include support for NetBSD/atari labels. If you don't set this option, it will be set automatically. NetBSD/atari will not work without it. options FALCON_SCSI Include support for the 5380-SCSI configuration as found on the Falcon. options RELOC_KERNEL If set, the kernel will relocate itself to TT-RAM, if possible. This will give you a slightly faster system. Beware that on some TT030 sys- tems, the system will frequently dump with MMU-faults with this option enabled. options SERCONSOLE Allow the modem1-port to act as the system-console. A carrier should be active on modem1 during system boot to active the console functionality. options TT_SCSI Include support for the 5380-SCSI configuration as found on the TT030 and Hades. i386-specific Options options I386_CPU,I486_CPU,I586_CPU,I686_CPU Include support for a particular class of CPU (i386, i486, Pentium, or Pentium Pro). If the appropriate class for your CPU is not configured, the kernel will use the highest class available that will work. In gen- eral, using the correct CPU class will result in the best performance. At least one of these options must be present. options CPURESET_DELAY=value specifies the time (in millisecond) to wait before doing a hardware reset in the last phase of a reboot. This gives the user a chance to see error messages from the shutdown operations (like NFS unmounts, buffer cache flush, etc ...). Setting this to 0 will disable the delay. Default is 2 seconds. options MATH_EMULATE Include the floating point emulator. This is useful only for CPUs that lack an internal Floating Point Unit (FPU) or co-processor. options VM86 Include support for virtual 8086 mode, used by DOS emulators and X servers to run BIOS code, e.g. for some VESA routines. options USER_LDT Include i386-specific system calls for modifying the local descriptor table, used by Windows emulators. options REALBASEMEM=integer Overrides the base memory size passed in from the boot block. (Value given in kilobytes.) Use this option only if the boot block reports the size incorrectly. (Note that some BIOSes put the extended BIOS data area at the top of base memory, and therefore report a smaller base memory size to prevent programs overwriting it. This is correct behavior, and you should not use the REALBASEMEM option to access this memory). options REALEXTMEM=integer Overrides the extended memory size passed in from the boot block. (Value given in kilobytes. Extended memory does not include the first megabyte.) Use this option only if the boot block reports the size incorrectly. options FRENCH_KBD,FINNISH_KBD,GERMAN_KBD,NORWEGIAN_KBD Select a non-US keyboard layout for the pccons console driver. options CYRIX_CACHE_WORKS Relevant only to the Cyrix 486DLC cpu. This option is used to turn on the cache in hold-flush mode. It is not turned on by default because it is known to have problems in certain motherboard implementations. options CYRIX_CACHE_REALLY_WORKS Relevant only to the Cyrix 486DLC cpu. This option is used to turn on the cache in write-back mode. It is not turned on by default because it is known to have problems in certain motherboard implementations. In order for this option to take effect, option CYRIX_CACHE_WORKS must also be specified. options PCIBIOS Enable support for initializing the PCI bus using information from the BIOS. See pcibios(4) for details. isa-specific Options Options specific to isa(4) busses. options PCIC_ISA_ALLOC_IOBASE=address, PCIC_ISA_ALLOC_IOSIZE=size Control the section of IO bus space used for PCMCIA bus space mapping. Ideally the probed defaults are satisfactory, however in practice that is not always the case. See pcmcia(4) for details. options PCIC_ISA_INTR_ALLOC_MASK=mask Controls the allowable interrupts that may be used for PCMCIA devices. This mask is a logical-or of power-of-2s of allowable interrupts: IRQ Val IRQ Val IRQ Val IRQ Val 0 0x0001 4 0x0010 8 0x0100 12 0x1000 1 0x0002 5 0x0020 9 0x0200 13 0x2000 2 0x0004 6 0x0040 10 0x0400 14 0x4000 3 0x0008 7 0x0080 11 0x0800 15 0x8000 m68k-specific Options options FPU_EMULATE Include support for MC68881/MC68882 emulator. options FPSP Include support for 68040 floating point. options M68020,M68030,M68040,M68060 Include support for a specific CPU, at least one (the one you are using) should be specified. options M060SP Include software support for 68060. This provides emulation of unimple- mented integer instructions as well as emulation of unimplemented float- ing point instructions and data types and software support for floating point traps. sparc-specific Options options AUDIO_DEBUG Enable simple event debugging of the logging of the audio(4) device. options BLINK Enable blinking of LED. Blink rate is full cycle every N seconds for N < then current load average. See getloadavg(3). options COUNT_SW_LEFTOVERS Count how many times the sw SCSI device has left 3, 2, 1 and 0 in the sw_3_leftover, sw_2_leftover, sw_1_leftover, and sw_0_leftover variables accessible from ddb(4). See sw(4). options DEBUG_ALIGN Adds debugging messages calls when user-requested alignment fault han- dling happens. options DEBUG_EMUL Adds debugging messages calls for emulated floating point and alignment fixing operations. options DEBUG_SVR4 Prints registers messages calls for emulated SVR4 getcontext and setcon- text operations. See options COMPAT_SVR4. options EXTREME_DEBUG Adds debugging functions callable from ddb(4). The debug_pagetables, test_region and print_fe_map functions print information about page ta- bles for the SUN4M platforms only. options EXTREME_EXTREME_DEBUG Adds extra info to options EXTREME_DEBUG. options FPU_CONTEXT Make options COMPAT_SVR4 getcontext and setcontext include floating point registers. options MAGMA_DEBUG Adds debugging messages to the magma(4) device. options RASTERCONS_FULLSCREEN Use the entire screen for the console. options RASTERCONS_SMALLFONT Use a the fixed font on the console, instead of the normal font. options SUN4 Support sun4 class machines. options SUN4C Support sun4c class machines. options SUN4M Support sun4m class machines. options SUN4_MMU3L Enable support for sun4 3-level MMU machines. options V9 Enable SPARC V9 assembler in ddb(4). sparc64-specific Options options AUDIO_DEBUG Enable simple event debugging of the logging of the audio(4) device. options BLINK Enable blinking of LED. Blink rate is full cycle every N seconds for N < then current load average. See getloadavg(3). x68k-specific Options options EXTENDED_MEMORY Include support for extended memory e.g. TS-6BE16 and 060turbo on-board. options JUPITER Include support for Jupiter-X MPU accelerator options ZSCONSOLE,ZSCN_SPEED=value Use the built-in serial port as the system-console. Speed is specified in bps, defaults to 9600. options ITE_KERNEL_ATTR=value Set the kernel message attribute for ITE. Value, an integer, is a logi- cal or of the following values: 1 color inversed 2 underlined 4 bolded
SEE ALSO
gdb(1), ktrace(1), quota(1), pmc(1), gettimeofday(2), i386_iopl(2), msgctl(2), msgget(2), msgrcv(2), msgsnd(2), ntp_adjtime(2), ntp_gettime(2), semctl(2), semget(2), semop(2), shmat(2), shmctl(2), shmdt(2), shmget(2), sysctl(3), apm(4), ddb(4), inet(4), iso(4), lkm(4), md(4), ns(4), pcibios(4), pcmcia(4), userconf(4), config(8), edquota(8), init(8), mdsetimage(8), mount_cd9660(8), mount_fdesc(8), mount_kernfs(8), mount_lfs(8), mount_mfs(8), mount_msdos(8), mount_nfs(8), mount_ntfs(8), mount_null(8), mount_portal(8), mount_procfs(8), mount_umap(8), mount_union(8), mrouted(8), newfs_lfs(8), ntpd(8), quotaon(8), rpc.rquotad(8), sysctl(8)
HISTORY
The options man page first appeared in NetBSD 1.3.
BUGS
The INET and the VNODEPAGER options should not be required. The EON op- tion should be a pseudo-device, and is also very fragile. NetBSD 1.6 November 20, 2001 19
Powered by man-cgi (2024-03-18). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.