init(8) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
INIT(8)                 NetBSD System Manager's Manual                 INIT(8)


NAME
init - process control initialization
SYNOPSIS
init
DESCRIPTION
The init program is the last stage of the boot process (after the kernel loads and initializes all the devices). It normally begins multi-user operation. The following table describes the state machine used by init: 1. Single user shell. init may be passed -s from the boot program to prevent the system from going multi-user and to instead execute a single user shell without starting the normal daemons. The system is then quiescent for maintenance work and may later be made to go to state 2 (multi-user) by exiting the single-user shell (with ^D). 2. Multi-user boot (default operation). Executes /etc/rc (see rc(8)). If this was the first state entered (as opposed to entering here af- ter state 1), then /etc/rc will be invoked with its first argument being `autoboot'. If /etc/rc exits with a non-zero (error) exit code, commence single user operation by giving the super-user a shell on the console by going to state 1 (single user). Otherwise, proceed to state 3. 3. Setup ttys as specified in ttys(5). See below for more information. On completion, continue to state 4. 4. Multi-user operation. Depending upon the signal received, change state appropriately; on SIGTERM, go to state 7; on SIGHUP, go to state 5; on SIGTSTP, go to state 6. 5. Clean-up mode; re-read ttys(5), killing off the controlling process- es on lines that are now `off', and starting processes that are new- ly `on'. On completion, go to state 4. 6. `Boring' mode; no new sessions. Signals as per state 4. 7. Shutdown mode. Send SIGHUP to all controlling processes, reap the processes for 30 seconds, and the go to state 1 (single user); warn- ing if not all the processes died. If the `console' entry in the ttys(5) file is marked ``insecure'', then init will require that the superuser password be entered before the sys- tem will start a single-user shell. The password check is skipped if the `console' is marked as ``secure''. The kernel runs with four different levels of security. Any superuser process can raise the security level, but only init can lower it. Secu- rity levels are defined as follows: -1 Permanently insecure mode - always run system in level 0 mode. 0 Insecure mode - immutable and append-only flags may be changed. All devices may be read or written subject to their permissions. 1 Secure mode - system immutable and system append-only flags may not be turned off; disks for mounted filesystems, /dev/mem, and /dev/kmem are read-only. 2 Highly secure mode - same as secure mode, plus disks are always read-only whether mounted or not, new disks may not be mounted, and existing mounts may only be downgraded from read-write to read-on- ly. This level precludes tampering with filesystems by unmounting them, but also inhibits running newfs(8) while the system is multi- user. The settimeofday(2) system call can only advance the time. The state of ipf(8) (the in-kernel IP filtering facility) may not be changed. Users may not change the per-process core name template format, on- ly the default can be changed. Downgrading from highly secure mode to insecure mode (that is, to single-user mode) always requires the root password to be entered on the console, whether the console is marked as 'secure' in /etc/ttys or not. Normally, the system runs in level 0 mode while single user and in level 1 mode while multi-user. If the level 2 mode is desired while running multi-user, it can be set in the startup script /etc/rc using sysctl(8). If it is desired to run the system in level 0 mode while multi-user, the administrator must build a kernel with options INSECURE in the kernel configuration file, which initializes the kernel's securelevel variable to -1. See options(4) and config(8) for details. In multi-user operation, init maintains processes for the terminal ports found in the file ttys(5). init reads this file, and executes the com- mand found in the second field. This command is usually getty(8); it opens and initializes the tty line and executes the login(1) program. The login(1) program, when a valid user logs in, executes a shell for that user. When this shell dies, either because the user logged out or an abnormal termination occurred (a signal), the init program wakes up, deletes the user from the utmp(5) file of current users and records the logout in the wtmp(5) file. The cycle is then restarted by init execut- ing a new getty(8) for the line. Line status (on, off, secure, getty, or window information) may be changed in the ttys(5) file without a reboot by sending the signal SIGHUP to init with the command ``kill -s HUP 1''. This is referenced in the table above as state 5. On receipt of this signal, init re-reads the ttys(5) file. When a line is turned off in ttys(5), init will send a SIGHUP signal to the controlling process for the session associated with the line. For any lines that were previously turned off in the ttys(5) file and are now on, init executes a new getty(8) to enable a new login. If the getty or window field for a line is changed, the change takes ef- fect at the end of the current login session (e.g., the next time init starts a process on the line). If a line is commented out or deleted from ttys(5), init will not do anything at all to that line. However, it will complain that the relationship between lines in the ttys(5) file and records in the utmp(5) file is out of sync, so this practice is not rec- ommended. init will terminate multi-user operations and resume single-user mode if sent a terminate (TERM) signal, for example, ``kill -s TERM 1''. If there are processes outstanding that are deadlocked (because of hardware or software failure), init will not wait for them all to die (which might take forever), but will time out after 30 seconds and print a warning message. init will cease creating new getty(8)'s and allow the system to slowly die away, if it is sent a terminal stop (TSTP) signal, i.e. ``kill -s TSTP 1''. A later hangup will resume full multi-user operations, or a terminate will start a single user shell. This hook is used by reboot(8) and halt(8). The role of init is so critical that if it dies, the system will reboot itself automatically. If, at bootstrap time, the init process cannot be located, the system will panic with the message ``panic: "init died (sig- nal %d, exit %d)''.
FILES
/dev/console System console device. /dev/tty* Terminal ports found in ttys(5). /var/run/utmp Record of Current users on the system. /var/log/wtmp Record of all logins and logouts. /etc/ttys The terminal initialization information file. /etc/rc System startup commands.
DIAGNOSTICS
getty repeating too quickly on port %s, sleeping A process being started to service a line is exiting quickly each time it is started. This is often caused by a ringing or noisy terminal line. Init will sleep for 10 seconds, then continue trying to start the process. some processes would not die; ps axl advised. A process is hung and could not be killed when the system was shutting down. This condition is usually caused by a process that is stuck in a device driver because of a persistent device error condition.
SEE ALSO
kill(1), login(1), sh(1), options(4), ttys(5), config(8), getty(8), halt(8), rc(8), reboot(8), shutdown(8)
HISTORY
A init command appeared in Version 6 AT&T UNIX.
BUGS
Systems without sysctl(8) behave as though they have security level -1. NetBSD 1.6 April 29, 2000 3
Powered by man-cgi (2024-03-18). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.