vn_lock(9) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
VNSUBR(9)              NetBSD Kernel Developer's Manual              VNSUBR(9)


NAME
vnsubr, vn_bwrite, vn_close, vn_default_error, vn_isunder, vn_lock, vn_markexec, vn_marktext, vn_rdwr, vn_restorerecurse, vn_setrecurse, vn_open, vn_stat, vn_writechk, vn_start_write, vn_finished_write, vn_cow_establish, vn_cow_disestablish - high-level convenience functions for vnode operations
SYNOPSIS
#include <sys/param.h> #include <sys/lock.h> #include <sys/vnode.h> int vn_bwrite(void *ap); int vn_close(struct vnode *vp, int flags, struct ucred *cred, struct proc *p); int vn_default_error(void *v); int vn_isunder(struct vnode *dvp, struct vnode *rvp, struct proc *p); int vn_lock(struct vnode *vp, int flags); void vn_markexec(struct vnode *vp); void vn_marktext(struct vnode *vp); u_int vn_setrecurse(struct vnode *vp); void vn_restorerecurse(struct vnode *vp, u_int flags); int vn_open(struct nameidata *ndp, int fmode, int cmode); int vn_rdwr(enum uio_rw rw, struct vnode *vp, caddr_t base, int len, off_t offset, enum uio_seg segflg, int ioflg, struct ucred *cred, size_t *aresid, struct proc *p); int vn_readdir(struct file *fp, char *buf, int segflg, u_int count, int *done, struct proc *p, off_t **cookies, int *ncookies); int vn_stat(struct vnode *vp, struct stat *sb, struct proc *p); int vn_writechk(struct vnode *vp); int vn_start_write(struct vnode *vp, struct mount **mpp, int flags); void vn_finished_write(struct mount *mp, int flags); int vn_cow_establish(struct vnode *vp, void (*func)(void *, struct buf *), void *cookie); int vn_cow_disestablish(struct vnode *vp, void (*func)(void *, struct buf *), void *cookie);
DESCRIPTION
The high-level functions described in this page are convenience functions for simplified access to the vnode operations described in vnodeops(9).
FUNCTIONS
vn_bwrite(ap) Common code for block write operations. vn_close(vp, flags, cred, p) Common code for a vnode close. The argument vp is the unlocked vnode of the vnode to close. vn_close() simply locks the vnode, invokes the vnode operation VOP_CLOSE(9) and calls vput() to return the vnode to the freelist or holdlist. Note that vn_close() expects an unlocked, referenced vnode and will deref- erence the vnode prior to returning. If the operation is suc- cessful zero is returned, otherwise an appropriate error is returned. vn_default_error(v) A generic "default" routine that just returns error. It is used by a file system to specify unsupported operations in the vnode operations vector. vn_isunder(dvp, rvp, p) Common code to check if one directory specified by the vnode rvp can be found inside the directory specified by the vnode dvp. The argument p is the calling process. vn_isunder() is intended to be used in chroot(2), chdir(2), fchdir(2), etc., to ensure that chroot(2) actually means something. If the operation is successful zero is returned, otherwise 1 is returned. vn_lock(vp, flags) Common code to acquire the lock for vnode vp. The argument flags specifies the lockmgr(9) flags used to lock the vnode. If the operation is successful zero is returned, otherwise an appropriate error code is returned. The vnode interlock v_interlock is releases on return. vn_lock() must not be called when the vnode's reference count is zero. Instead, vget(9) should be used. vn_markexec(vp) Common code to mark the vnode vp as containing executable code of a running process. vn_marktext(vp) Common code to mark the vnode vp as being the text of a running process. vn_setrecurse(vp) Common code to enable LK_CANRECURSE on the vnode lock for vnode vp. vn_setrecurse() returns the new lockmgr(9) flags after the update. vn_restorerecurse(vp, flags) Common code to restore the vnode lock flags for the vnode vp. It is called when done with vn_setrecurse(). vn_open(ndp, fmode, cmode) Common code for vnode open operations. The pathname is described in the nameidata pointer (see namei(9)). The argu- ments fmode and cmode specify the open(2) file mode and the access permissions for creation. vn_open() checks permissions and invokes the VOP_OPEN(9) or VOP_CREATE(9) vnode operations. If the operation is successful zero is returned, otherwise an appropriate error code is returned. vn_rdwr(rw, vp, base, len, offset, segflg, ioflg, cred, aresid, p) Common code to package up an I/O request on a vnode into a uio and then perform the I/O. The argument rw specifies whether the I/O is a read (UIO_READ) or write (UIO_WRITE) operation. The unlocked vnode is specified by vp. The arguments p and cred are the calling process and its credentials. The remaining argu- ments specify the uio parameters. For further information on these parameters see uiomove(9). vn_readdir(fp, buf, segflg, count, done, p, cookies, ncookies) Common code for reading the contents of a directory. The argu- ment fp is the file structure, buf is the buffer for placing the struct dirent structures. The arguments cookies and ncookies specify the addresses for the list and number of directory seek cookies generated for NFS. Both cookies and ncookies should be NULL is they aren't required to be returned by vn_readdir(). If the operation is successful zero is returned, otherwise an appropriate error code is returned. vn_stat(vp, sb, p) Common code for a vnode stat operation. The vnode is specified by the argument vp and sb is the buffer to return the stat information. The argument p is the calling process. vn_stat() basically calls the vnode operation VOP_GETATTR(9) and transfer the contents of a vattr structure into a struct stat. If the operation is successful zero is returned, otherwise an appropri- ate error code is returned. vn_writechk(vp) Common code to check for write permission on the vnode vp. A vnode is read-only if it is in use as a process's text image. If the vnode is read-only ETEXTBSY is returned, otherwise zero is returned to indicate that the vnode can be written to. vn_start_write(vp, mpp, flags) Prepare to start a file system write operation. If the opera- tion is permitted, bump the count of operations in progress and proceed. If a suspend request is in progress (see vfs_write_suspend(9)), wait until the suspension is over and proceed. If vp is not NULL, its mount point is assigned to mpp. If the V_WAIT flag is set, vn_start_write() waits until the sus- pension is over. Otherwise it returns EWOULDBLOCK. If the V_PCATCH flag is set, PCATCH gets added to the tsleep() flags. If the V_SLEEPONLY flag is set, the operations count is not bumped. If the V_LOWER flag is set, no further vnodes must be locked. If it is not set, no vnodes must be already locked. If the operation is permitted zero is returned, otherwise EWOULDBLOCK is returned. vn_finished_write(mp, flags) A file system write operation has finished. Adjust the count of operations in progress and return. Only the V_LOWER flag is valid. vn_cow_establish(vp, func, cookie) Establish a copy-on-write callback on spec vnode vp. func will be called for every buffer written through the strategy routine of vp. vn_cow_disestablish(vp, func, cookie) Disestablish a copy-on-write callback registered with vn_cow_establish().
ERRORS
[ETXTBSY] Cannot write to a vnode since is a process's text image. [ENOENT] The vnode has been reclaimed and is dead. This error is only returned if the LK_RETRY flag is not passed to vn_lock(). [EBUSY] The LK_NOWAIT flag was set and vn_lock() would have slept.
CODE REFERENCES
This section describes places within the NetBSD source tree where actual code implementing or using the vnode framework can be found. All path- names are relative to /usr/src. The high-level convenience functions are implemented within the files sys/kern/vfs_vnops.c and sys/sys/vnode.h.
SEE ALSO
file(9), intro(9), lock(9), namei(9), vattr(9), vfs(9), vnode(9), vnodeops(9) NetBSD 2.0.2 March 14, 2004 NetBSD 2.0.2
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.