signal(7) - NetBSD Manual Pages

Command: Section: Arch: Collection:  
SIGNAL(7)                   NetBSD Reference Manual                  SIGNAL(7)


NAME
signal - signal facilities
DESCRIPTION
The <signal.h> header file defines the following signals: Name Default Action Description SIGHUP terminate process terminal line hangup SIGINT terminate process interrupt program SIGQUIT create core image quit program SIGILL create core image illegal instruction SIGTRAP create core image trace trap SIGABRT create core image abort(3) call (formerly SIGIOT) SIGEMT create core image emulate instruction executed SIGFPE create core image floating-point exception SIGKILL terminate process kill program (cannot be caught or ignored) SIGBUS create core image bus error SIGSEGV create core image segmentation violation SIGSYS create core image invalid system call argument SIGPIPE terminate process write to a pipe with no reader SIGALRM terminate process real-time timer expired SIGTERM terminate process software termination signal SIGURG discard signal urgent condition present on socket SIGSTOP stop process stop (cannot be caught or ignored) SIGTSTP stop process stop signal generated from keyboard SIGCONT discard signal continue after stop SIGCHLD discard signal child status has changed SIGTTIN stop process background read attempted from control terminal SIGTTOU stop process background write attempted to control terminal SIGIO discard signal I/O is possible on a descriptor (see fcntl(2)) SIGXCPU terminate process CPU time limit exceeded (see setrlimit(2)) SIGXFSZ terminate process file size limit exceeded (see setrlimit(2)) SIGVTALRM terminate process virtual time alarm (see setitimer(2)) SIGPROF terminate process profiling timer alarm (see setitimer(2)) SIGWINCH discard signal window size change SIGINFO discard signal status request from keyboard SIGUSR1 terminate process user-defined signal 1 SIGUSR2 terminate process user-defined signal 2 SIGPWR discard signal power failure/restart
STANDARDS
These signals conform to IEEE Std 1003.1-1990 (``POSIX''), with the ex- ception of SIGTRAP, SIGEMT, SIGBUS, SIGSYS, SIGURG, SIGIO, SIGXCPU, SIGXFSZ, SIGVTALRM, SIGPROF, SIGWINCH, and SIGINFO which are Berkeley ex- tensions (available on most BSD-derived systems), and SIGPWR which comes from System V.
HISTORY
SIGPWR was introduced in NetBSD 1.4.
NOTES
The current NetBSD kernel never generates the SIGPWR signal.
SEE ALSO
kill(1), kill(2), ptrace(2), sigaction(2), sigaltstack(2), sigprocmask(2), sigstack(2), sigsuspend(2), fpgetmask(3), fpsetmask(3), setjmp(3), sigblock(3), siginterrupt(3), signal(3), sigpause(3), sigsetmask(3), sigsetops(3), tty(4) NetBSD 1.6 September 27, 1999 2
Powered by man-cgi (2024-03-20). Maintained for NetBSD by Kimmo Suominen. Based on man-cgi by Panagiotis Christias.